summaryrefslogtreecommitdiff
path: root/gnu/packages/avr.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2016-04-14 08:44:46 -0400
committerDavid Thompson <dthompson2@worcester.edu>2016-05-30 13:45:21 -0400
commite60972f28847f4a207186754a954dbebe92f207f (patch)
treeffb0563b2f55fdbace9b983479c41a9b631a3222 /gnu/packages/avr.scm
parenta17eea4ba41fc0ab234db618770727da3432be8a (diff)
downloadguix-patches-e60972f28847f4a207186754a954dbebe92f207f.tar
guix-patches-e60972f28847f4a207186754a954dbebe92f207f.tar.gz
gnu: avr-libc: Fix build.
* gnu/packages/avr.scm (avr-libc): Update to 2.0.0. [native-inputs]: Use new avr-gcc and avr-binutils. [arguments]: Add phase to unset C_INCLUDE_PATH.
Diffstat (limited to 'gnu/packages/avr.scm')
-rw-r--r--gnu/packages/avr.scm23
1 files changed, 17 insertions, 6 deletions
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index 00c4e47ebe..72411d9251 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -84,17 +84,28 @@
"0sd9qkvhmk9av4g1f8dsjwc309hf1g0731bhvicnjb3b3d42l1n3"))))
(build-system gnu-build-system)
(arguments
- `(#:out-of-source? #t
- #:configure-flags '("--host=avr")))
-
- (native-inputs `(("cross-binutils" ,(cross-binutils "avr"))
- ("cross-gcc" ,xgcc-avr)))
+ '(#:out-of-source? #t
+ #:configure-flags '("--host=avr")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'unpack 'fix-cpath
+ (lambda _
+ ;; C_INCLUDE_PATH poses issues for cross-building, leading to
+ ;; failures when building avr-libc on 64-bit systems. Simply
+ ;; unsetting it allows the build to succeed because it doesn't
+ ;; try to use any of the native system's headers.
+ (unsetenv "C_INCLUDE_PATH")
+ #t)))))
+ (native-inputs `(("avr-binutils" ,avr-binutils)
+ ("avr-gcc" ,avr-gcc-4.9)))
(home-page "http://www.nongnu.org/avr-libc/")
(synopsis "The AVR C Library")
(description
"AVR Libc is a project whose goal is to provide a high quality C library
for use with GCC on Atmel AVR microcontrollers.")
- (license (license:non-copyleft "http://www.nongnu.org/avr-libc/LICENSE.txt"))))
+ (license
+ (license:non-copyleft "http://www.nongnu.org/avr-libc/LICENSE.txt"))))
+
(define-public microscheme
(package