summaryrefslogtreecommitdiff
path: root/gnu/packages/avahi.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-26 00:15:26 -0500
committerMark H Weaver <mhw@netris.org>2018-01-26 00:15:26 -0500
commitb89d8a4271c8ef02c9b1e51a2c86341cdc09c760 (patch)
treef8e763584ac99d810135956cb09511434a703821 /gnu/packages/avahi.scm
parent7bf0170e9fbcb08f9edb875dc08e27584826a1c2 (diff)
parenta81f7eb858bf7e320d4dccde183d303247b6d47a (diff)
downloadguix-patches-b89d8a4271c8ef02c9b1e51a2c86341cdc09c760.tar
guix-patches-b89d8a4271c8ef02c9b1e51a2c86341cdc09c760.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/avahi.scm')
-rw-r--r--gnu/packages/avahi.scm36
1 files changed, 12 insertions, 24 deletions
diff --git a/gnu/packages/avahi.scm b/gnu/packages/avahi.scm
index 94af0a1be3..661214e23a 100644
--- a/gnu/packages/avahi.scm
+++ b/gnu/packages/avahi.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -76,39 +77,26 @@ DNS-SD (for \"DNS-Based Service Discovery\") protocols.")
(define-public nss-mdns
(package
(name "nss-mdns")
- (version "0.10")
+ (version "0.11")
(source (origin
(method url-fetch)
- (uri (list
- (string-append
- "mirror://debian/pool/main/n/nss-mdns/nss-mdns_"
- version ".orig.tar.gz")
- "http://pkgs.fedoraproject.org/repo/pkgs/nss-mdns/nss-mdns-0.10.tar.gz/03938f17646efbb50aa70ba5f99f51d7/nss-mdns-0.10.tar.gz"
-
- ;; This used to be the canonical URL but it vanished.
- ;; See <http://bugs.gnu.org/18704>.
- ;; (string-append
- ;; "http://0pointer.de/lennart/projects/nss-mdns/nss-mdns-"
- ;; version ".tar.gz")
- ))
+ (uri (string-append "https://github.com/lathiat/nss-mdns"
+ "/releases/download/v" version "/"
+ name "-" version ".tar.gz"))
(sha256
(base32
- "0vgs6j0qsl0mwzh5a0m0bykr7x6bx79vnbyn0r3q289rghp3qs0y"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ "14jwy6mklzgjz3mfmw67mxhszrw9d3d3yjjhg87j4crci6m19i39"))))
(build-system gnu-build-system)
(arguments
;; The Avahi daemon socket is expected by src/Makefile.am to be at
;; "$(localstatedir)/run/avahi-daemon/socket", so set $(localstatedir)
;; appropriately.
'(#:configure-flags '("--localstatedir=/var")))
-
- ;; XXX: Stale URL, missing replacement. See <http://bugs.gnu.org/18704>.
- (home-page "http://0pointer.de/lennart/projects/nss-mdns/")
-
- (synopsis "The mDNS Name Service Switch (NSS) plug-in")
+ (home-page "https://github.com/lathiat/nss-mdns")
+ (synopsis "Multicast DNS Name Service Switch (@dfn{NSS}) plug-in")
(description
- "Nss-mdns is a plug-in for the Name Service Switch (NSS) functionality
-of the GNU C Library, providing host name resolution via Multicast DNS (mDNS).
-It allows for name resolution by programs in the ad-hoc mDNS domain
-'.local'.")
+ "Nss-mdns is a plug-in for the GNU C Library's Name Service Switch
+(@dfn{NSS}) that resolves host names via multicast DNS (@dfn{mDNS}). It is
+most often used in home and other small networks without a local name server,
+to resolve host names in the @samp{.local} top-level domain.")
(license lgpl2.1+)))