summaryrefslogtreecommitdiff
path: root/gnu/packages/avahi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-09 15:16:09 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-09 15:17:41 +0100
commita68fdfea96370c8a4b95af1fcd6e2fd7eb72da29 (patch)
tree681d676b54df9273b5216602ca01974994589515 /gnu/packages/avahi.scm
parent8f8842cc7be41cdf55c240352f03db5f55d7881f (diff)
downloadguix-patches-a68fdfea96370c8a4b95af1fcd6e2fd7eb72da29.tar
guix-patches-a68fdfea96370c8a4b95af1fcd6e2fd7eb72da29.tar.gz
services: avahi: Default to nss-mdns 0.10.
This works around <https://bugs.gnu.org/30396>. Reported by George myglc2 Clemmer <myglc2@gmail.com>. * gnu/packages/avahi.scm (nss-mdns-0.10): New variable. * gnu/services/avahi.scm (avahi-service-type): Use it.
Diffstat (limited to 'gnu/packages/avahi.scm')
-rw-r--r--gnu/packages/avahi.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/avahi.scm b/gnu/packages/avahi.scm
index f4d17c5c15..001afa8d48 100644
--- a/gnu/packages/avahi.scm
+++ b/gnu/packages/avahi.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
@@ -100,3 +100,28 @@ DNS-SD (for \"DNS-Based Service Discovery\") protocols.")
most often used in home and other small networks without a local name server,
to resolve host names in the @samp{.local} top-level domain.")
(license lgpl2.1+)))
+
+(define-public nss-mdns-0.10
+ ;; Kept here to work around in bug in 0.11: <https://bugs.gnu.org/30396> and
+ ;; <https://github.com/lathiat/nss-mdns/issues/26>.
+ (package
+ (inherit nss-mdns)
+ (version "0.10")
+ (source (origin
+ (method url-fetch)
+ (uri (list
+ (string-append
+ "mirror://debian/pool/main/n/nss-mdns/nss-mdns_"
+ version ".orig.tar.gz")
+ "http://pkgs.fedoraproject.org/repo/pkgs/nss-mdns/nss-mdns-0.10.tar.gz/03938f17646efbb50aa70ba5f99f51d7/nss-mdns-0.10.tar.gz"
+
+ ;; This used to be the canonical URL but it vanished.
+ ;; See <http://bugs.gnu.org/18704>.
+ ;; (string-append
+ ;; "http://0pointer.de/lennart/projects/nss-mdns/nss-mdns-"
+ ;; version ".tar.gz")
+ ))
+ (sha256
+ (base32
+ "0vgs6j0qsl0mwzh5a0m0bykr7x6bx79vnbyn0r3q289rghp3qs0y"))
+ (file-name (string-append "nss-mdns-" version ".tar.gz"))))))