summaryrefslogtreecommitdiff
path: root/gnu/packages/avahi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-08-29 14:13:26 +0200
committerLudovic Courtès <ludo@gnu.org>2014-08-29 14:13:26 +0200
commit00b7776c0dc294c26c3b09bff236ccacbedd2080 (patch)
treeba98e516ca7d476555ffa488b0fcce6b604f4eed /gnu/packages/avahi.scm
parentdd16424466196616b99c13526537a89aaee27f88 (diff)
downloadguix-patches-00b7776c0dc294c26c3b09bff236ccacbedd2080.tar
guix-patches-00b7776c0dc294c26c3b09bff236ccacbedd2080.tar.gz
gnu: Add nss-mdns.
* gnu/packages/avahi.scm (nss-mdns): New variable.
Diffstat (limited to 'gnu/packages/avahi.scm')
-rw-r--r--gnu/packages/avahi.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/avahi.scm b/gnu/packages/avahi.scm
index d3a92844c2..3f2fdffc28 100644
--- a/gnu/packages/avahi.scm
+++ b/gnu/packages/avahi.scm
@@ -68,3 +68,25 @@
network. It is an implementation of the mDNS (for \"Multicast DNS\") and
DNS-SD (for \"DNS-Based Service Discovery\") protocols.")
(license lgpl2.1+)))
+
+(define-public nss-mdns
+ (package
+ (name "nss-mdns")
+ (version "0.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://0pointer.de/lennart/projects/nss-mdns/nss-mdns-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0vgs6j0qsl0mwzh5a0m0bykr7x6bx79vnbyn0r3q289rghp3qs0y"))))
+ (build-system gnu-build-system)
+ (home-page "http://0pointer.de/lennart/projects/nss-mdns/")
+ (synopsis "The mDNS Name Service Switch (NSS) plug-in")
+ (description
+ "'nss-mdns' is a plug-in for the Name Service Switch (NSS) functionality
+of the GNU C Library, providing host name resolution via Multicast DNS (mDNS).
+It allows for name resolution by programs in the ad-hoc mDNS domain
+'.local'.")
+ (license lgpl2.1+)))