summaryrefslogtreecommitdiff
path: root/gnu/packages/aux-files
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-07-30 15:54:31 +0200
committerMarius Bakke <marius@gnu.org>2021-07-30 15:54:31 +0200
commitf8458a228224942298e0967a099f872c13713ede (patch)
tree3a2e0b9a3a10f16a30768156f5c71603cf97153b /gnu/packages/aux-files
parentb029be2ee0f81cdcbc14240ff426408085ab0a40 (diff)
downloadguix-patches-f8458a228224942298e0967a099f872c13713ede.tar
guix-patches-f8458a228224942298e0967a099f872c13713ede.tar.gz
build-system/python: Handle missing metadata on Python 2.
* gnu/packages/aux-files/python/sanity-check.py: Catch the less specific EnvironmentError rather than FileNotFoundError as the latter is Python 3 only.
Diffstat (limited to 'gnu/packages/aux-files')
-rw-r--r--gnu/packages/aux-files/python/sanity-check.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/aux-files/python/sanity-check.py b/gnu/packages/aux-files/python/sanity-check.py
index 83b6d583ca..a84f8f03c0 100644
--- a/gnu/packages/aux-files/python/sanity-check.py
+++ b/gnu/packages/aux-files/python/sanity-check.py
@@ -51,7 +51,7 @@ for dist in ws:
# Try to load top level modules. This should not have any side-effects.
try:
metalines = dist.get_metadata_lines('top_level.txt')
- except (KeyError, FileNotFoundError):
+ except (KeyError, EnvironmentError):
# distutils (i.e. #:use-setuptools? #f) will not install any metadata.
# This file is also missing for packages built using a PEP 517 builder
# such as poetry.