summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-04-20 00:42:15 -0400
committerMark H Weaver <mhw@netris.org>2017-04-21 00:04:43 -0400
commitfe18e2571c10a3702d9239401a2ad04d8378ce1d (patch)
tree92d9f41947acee5117b47b7a5569dcec592081d4 /gnu/packages/autotools.scm
parent6be43d95b5844c119869f29451b78dd9f71511e1 (diff)
downloadguix-patches-fe18e2571c10a3702d9239401a2ad04d8378ce1d.tar
guix-patches-fe18e2571c10a3702d9239401a2ad04d8378ce1d.tar.gz
gnu: Add autoconf@2.13.
* gnu/packages/autotools.scm (autoconf-2.13): New variable.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index e8b087000f..4dbe7b2a21 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
-;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2017 ng0 <ng0@libertad.pw>
;;;
@@ -92,6 +92,35 @@ know anything about Autoconf or M4.")
(base32
"0j3jdjpf5ly39dlp0bg70h72nzqr059k0x8iqxvaxf106chpgn9j"))))))
+(define-public autoconf-2.13
+ ;; GNU IceCat 52.x requires autoconf-2.13 to build!
+ (package (inherit autoconf)
+ (version "2.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/autoconf/autoconf-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "07krzl4czczdsgzrrw9fiqx35xcf32naf751khg821g5pqv12qgh"))))
+ (arguments
+ `(#:tests? #f
+ #:phases
+ ;; The 'configure' script in autoconf-2.13 can't cope with "SHELL=" and
+ ;; "CONFIG_SHELL=" arguments, so we set them as environment variables
+ ;; and pass a simplified set of arguments.
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key build inputs outputs #:allow-other-keys)
+ (let ((bash (which "bash"))
+ (out (assoc-ref outputs "out")))
+ (setenv "CONFIG_SHELL" bash)
+ (setenv "SHELL" bash)
+ (zero? (system* bash "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--build=" build)))))))))))
+
(define* (autoconf-wrapper #:optional (autoconf autoconf))
"Return an wrapper around AUTOCONF that generates `configure' scripts that