summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-26 19:47:54 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-26 19:47:54 +0100
commitecbea1bcb1e349eb66140cb3b83329f9699c357a (patch)
tree94969e35b60f4fbf0a6b67b4d7f8132be0e8da92 /gnu/packages/autotools.scm
parent1d84d7bf6052c0c80bd212d4524876576e9817d4 (diff)
downloadguix-patches-ecbea1bcb1e349eb66140cb3b83329f9699c357a.tar
guix-patches-ecbea1bcb1e349eb66140cb3b83329f9699c357a.tar.gz
gnu: automake: Add 1.16.
* gnu/packages/autotools.scm (automake-1.16): New variable.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 355e66f42a..846e318aa1 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2015, 2017 Mark H Weaver <mhw@netris.org>
@@ -315,6 +315,21 @@ intuitive format and then Automake works with Autoconf to produce a robust
Makefile, simplifying the entire process for the developer.")
(license gpl2+))) ; some files are under GPLv3+
+(define-public automake-1.16
+ ;; Make this the default on the next rebuild cycle.
+ (package
+ (inherit automake)
+ (version "1.16")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/automake/automake-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "12jvcmkcmd5p14b41w9f7ixd3sca97pymd6lqbkwnl8qn6bjv3zr"))
+ (patches
+ (search-patches "automake-skip-amhello-tests.patch"))))))
+
(define-public libtool
(package
(name "libtool")