summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-03 23:35:43 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-03 23:35:43 +0100
commite13f715be0d609073974b1d464771638887a00c6 (patch)
tree5890eae5659678fe77b9f198a0aae207ba3f0e4f /gnu/packages/autotools.scm
parent4b2fd119befd4b4fdeb596bfc12fa0082ba94507 (diff)
downloadguix-patches-e13f715be0d609073974b1d464771638887a00c6.tar
guix-patches-e13f715be0d609073974b1d464771638887a00c6.tar.gz
gnu: libtool: Add 2.4.4.
* gnu/packages/patches/libtool-2.4-skip-tests.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/autotools.scm (libtool-2.4.4): New variable.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 0094577210..3d5c85463f 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -291,3 +291,20 @@ presenting a single consistent, portable interface that hides the usual
complexity of working with shared libraries across platforms.")
(license gpl3+)
(home-page "http://www.gnu.org/software/libtool/")))
+
+(define-public libtool-2.4.4
+ (package (inherit libtool)
+ (version "2.4.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/libtool/libtool-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0v3zq08qxv7k5067mpqrkjkjl3wphhg06i696mka90mzadc5nad8"))
+ (patches
+ (list (search-patch "libtool-2.4-skip-tests.patch")))))
+
+ (native-inputs `(("automake" ,automake) ;some tests rely on 'aclocal'
+ ("autoconf" ,(autoconf-wrapper)) ;others on 'autom4te'
+ ,@(package-native-inputs libtool)))))