summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-06 23:22:00 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-07 16:48:50 +0100
commitc154e1ea81b1eb81c5716ce5a4df694fbd05c421 (patch)
treedf9d24e04464ee55f7cb6494bcd9878c6c3a2f34 /gnu/packages/autotools.scm
parentbe11b1024474489ead4d6befa40d38fd39fb9b72 (diff)
downloadguix-patches-c154e1ea81b1eb81c5716ce5a4df694fbd05c421.tar
guix-patches-c154e1ea81b1eb81c5716ce5a4df694fbd05c421.tar.gz
gnu: libtool: Update to 2.4.4.
* gnu/packages/patches/libtool-2.4-skip-tests.patch: Rename to... * gnu/packages/patches/libtool-skip-tests.patch: ... this. * gnu/packages/patches/libtool-skip-tests-for-mips.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly. * gnu/packages/autotools.scm (libtool): Update to 2.4.4. (libtool-2.4.4): Remove.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm63
1 files changed, 22 insertions, 41 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index eb33009d83..0ee1d149b9 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -238,31 +238,38 @@ Makefile, simplifying the entire process for the developer.")
(define-public libtool
(package
(name "libtool")
- (version "2.4.2")
+ (version "2.4.4")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/libtool/libtool-"
- version ".tar.gz"))
- (sha256
- (base32
- "0649qfpzkswgcj9vqkkr9rn4nlcx80faxpyqscy2k1x9c94f93dk"))
- (patches
- (list (search-patch "libtool-skip-tests.patch")
- (search-patch "libtool-skip-tests-for-mips.patch")))))
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/libtool/libtool-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0v3zq08qxv7k5067mpqrkjkjl3wphhg06i696mka90mzadc5nad8"))
+ (patches
+ (list (search-patch "libtool-skip-tests.patch")))))
(build-system gnu-build-system)
(native-inputs `(("m4" ,m4)
- ("perl" ,perl)))
+ ("perl" ,perl)
+ ("automake" ,automake) ;some tests rely on 'aclocal'
+ ("autoconf" ,(autoconf-wrapper)))) ;others on 'autom4te'
;; Separate binaries from the rest. During bootstrap, only ltdl is
;; used; not depending on the binaries allows us to avoid retaining
;; a reference to the bootstrap bash.
- (outputs '("bin" ; libtoolize, libtool, etc.
- "out")) ; libltdl.so, ltdl.h, etc.
+ (outputs '("bin" ;libtoolize, libtool, etc.
+ "out")) ;libltdl.so, ltdl.h, etc.
(arguments
(if (%current-target-system)
- '() ; no `check' phase when cross-building
- '(#:phases (alist-cons-before
+ '() ;no `check' phase when cross-building
+ `(;; XXX: There are test failures on mips64el-linux starting from 2.4.4:
+ ;; <http://hydra.gnu.org/build/181662>.
+ #:tests? ,(not (string-prefix? "mips64"
+ (or (%current-target-system)
+ (%current-system))))
+
+ #:phases (alist-cons-before
'check 'pre-check
(lambda* (#:key inputs #:allow-other-keys)
;; Run the test suite in parallel, if possible.
@@ -285,32 +292,6 @@ complexity of working with shared libraries across platforms.")
(license gpl3+)
(home-page "http://www.gnu.org/software/libtool/")))
-(define-public libtool-2.4.4
- (package (inherit libtool)
- (version "2.4.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/libtool/libtool-"
- version ".tar.xz"))
- (sha256
- (base32
- "0v3zq08qxv7k5067mpqrkjkjl3wphhg06i696mka90mzadc5nad8"))
- (patches
- (list (search-patch "libtool-2.4-skip-tests.patch")))))
-
- (native-inputs `(("automake" ,automake) ;some tests rely on 'aclocal'
- ("autoconf" ,(autoconf-wrapper)) ;others on 'autom4te'
- ,@(package-native-inputs libtool)))
-
- (arguments
- ;; XXX: There are test failures on mips64el-linux starting from 2.4.4:
- ;; <http://hydra.gnu.org/build/181662>.
- (if (string-prefix? "mips64el"
- (or (%current-target-system) (%current-system)))
- `(#:tests? #f
- ,@(package-arguments libtool))
- (package-arguments libtool)))))
-
(define-public libltdl
;; This is a libltdl package separate from the libtool package. This is
;; useful because, unlike libtool, it has zero extra dependencies (making it