summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-23 17:01:07 -0500
committerMark H Weaver <mhw@netris.org>2018-01-23 17:01:07 -0500
commita102d359a68ce7219a1880e47dd6f9332cbbce3a (patch)
treed879e718f08d776ad84c456c91a349e59941d1f2 /gnu/packages/autotools.scm
parent07b8ea841e1e2eda5b367f35cf68d23d0520cc4d (diff)
parentf3a13a21e50fa3751fc39e5768ea6843bfc19df2 (diff)
downloadguix-patches-a102d359a68ce7219a1880e47dd6f9332cbbce3a.tar
guix-patches-a102d359a68ce7219a1880e47dd6f9332cbbce3a.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index b45800f0a1..355e66f42a 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -27,6 +27,7 @@
#:use-module (guix licenses)
#:use-module (gnu packages)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages python)
#:use-module (gnu packages m4)
#:use-module (gnu packages man)
#:use-module (gnu packages bash)
@@ -399,3 +400,38 @@ complexity of working with shared libraries across platforms.")
(description (package-description libtool))
(home-page (package-home-page libtool))
(license lgpl2.1+)))
+
+(define-public pyconfigure
+ (package
+ (name "pyconfigure")
+ (version "0.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/pyconfigure/pyconfigure-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0kxi9bg7l6ric39vbz9ykz4a21xlihhh2zcc3297db8amvhqwhrp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-python
+ (lambda _
+ (substitute* "pyconf.in"
+ (("/usr/bin/env python") (which "python3")))
+ #t)))))
+ (inputs
+ `(("python" ,python-3)))
+ (synopsis "@command{configure} interface for Python-based packages")
+ (description
+ "GNU pyconfigure provides template files for easily implementing
+standards-compliant configure scripts and Makefiles for Python-based packages.
+It is designed to work alongside existing Python setup scripts, making it easy
+to integrate into existing projects. Powerful and flexible Autoconf macros
+are available, allowing you to easily make adjustments to the installation
+procedure based on the capabilities of the target computer.")
+ (home-page "https://www.gnu.org/software/pyconfigure/manual/")
+ (license
+ (fsf-free
+ "https://www.gnu.org/prep/maintain/html_node/License-Notices-for-Other-Files.html"))))