summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-15 13:07:37 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-15 14:23:46 +0100
commit89b48232f80d58e100ec7b73ee27ee513a58cfcc (patch)
tree034fc6cee2e57047c3957b3f8daee8318829ba72 /gnu/packages/autotools.scm
parent76002e54f2280f5a6416438c513aab14ecddb138 (diff)
downloadguix-patches-89b48232f80d58e100ec7b73ee27ee513a58cfcc.tar
guix-patches-89b48232f80d58e100ec7b73ee27ee513a58cfcc.tar.gz
gnu: automake: Adjust to deal with Perl 5.22.
Fixes <http://bugs.gnu.org/22375>. * gnu/packages/patches/automake-regexp-syntax.patch: New file. * gnu/packages/autotools.scm (automake)[source]: Use it. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 0d9a5b5873..598624ccdc 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
@@ -195,7 +195,9 @@ output is indexed in many ways to simplify browsing.")
(base32
"0dl6vfi2lzz8alnklwxzfz624b95hb1ipjvd3mk177flmddcf24r"))
(patches
- (list (search-patch "automake-skip-amhello-tests.patch")))))
+ (map search-patch
+ '("automake-regexp-syntax.patch"
+ "automake-skip-amhello-tests.patch")))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,(autoconf-wrapper))