summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-30 22:31:10 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-30 22:31:10 +0200
commit706448b193406fcc50535d722196ee9bb0d99934 (patch)
tree630a9a8da14ebc2f68b087f72fbf74e1124e9022 /gnu/packages/autotools.scm
parentc91171627b5e8351c1b0251cc64ddfea2d952869 (diff)
downloadguix-patches-706448b193406fcc50535d722196ee9bb0d99934.tar
guix-patches-706448b193406fcc50535d722196ee9bb0d99934.tar.gz
gnu: automake: Add 1.15.1.
* gnu/packages/autotools.scm (automake/latest): New variable.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 4dbe7b2a21..30a9aac824 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2015, 2017 Mark H Weaver <mhw@netris.org>
@@ -237,6 +237,7 @@ output is indexed in many ways to simplify browsing.")
(license gpl3+)))
(define-public automake
+ ;; Replace with 'automake/latest' on the next rebuild cycle.
(package
(name "automake")
(version "1.15")
@@ -315,6 +316,22 @@ intuitive format and then Automake works with Autoconf to produce a robust
Makefile, simplifying the entire process for the developer.")
(license gpl2+))) ; some files are under GPLv3+
+
+(define-public automake/latest
+ ;; Merge with 'automake' on the next rebuild cycle.
+ (package
+ (inherit automake)
+ (version "1.15.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/automake/automake-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1bzd9g32dfm4rsbw93ld9x7b5nc1y6i4m6zp032qf1i28a8s6sxg"))
+ (patches
+ (search-patches "automake-skip-amhello-tests.patch"))))))
+
(define-public libtool
(package
(name "libtool")