summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorPierre-Moana Levesque <pierre.moana.levesque@gmail.com>2019-07-04 19:18:48 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:14:15 +0200
commit647cfcf68184e8558fcea751ef6d95b6e5d86ae1 (patch)
tree44af1ad1bdccf6f388eff7bf4bf6c68a21da0757 /gnu/packages/autotools.scm
parent06b2bc550fdcd943e19471873e0838e712217681 (diff)
downloadguix-patches-647cfcf68184e8558fcea751ef6d95b6e5d86ae1.tar
guix-patches-647cfcf68184e8558fcea751ef6d95b6e5d86ae1.tar.gz
gnu: libtool: Fix cross-compilation.
* gnu/packages/autotools.scm (libtool)[arguments]: Do not run tests and use bash from native-inputs when cross-compiling.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index ceb70dfee7..98f31f6bca 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -354,21 +355,22 @@ Makefile, simplifying the entire process for the developer.")
;; XXX: There are test failures on mips64el-linux starting from 2.4.4:
;; <http://hydra.gnu.org/build/181662>.
- #:tests? ,(not (string-prefix? "mips64"
- (or (%current-target-system)
+ ;; Also, do not run tests when cross compiling
+ #:tests? ,(not (or (%current-target-system)
+ (string-prefix? "mips64"
(%current-system))))
#:phases
(modify-phases %standard-phases
(add-before 'check 'pre-check
- (lambda* (#:key inputs #:allow-other-keys)
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
;; Run the test suite in parallel, if possible.
(setenv "TESTSUITEFLAGS"
(string-append
"-j"
(number->string (parallel-job-count))))
;; Patch references to /bin/sh.
- (let ((bash (assoc-ref inputs "bash")))
+ (let ((bash (assoc-ref (or native-inputs inputs) "bash")))
(substitute* "tests/testsuite"
(("/bin/sh")
(string-append bash "/bin/sh")))