summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-03-09 23:11:48 +0100
committerLudovic Courtès <ludo@gnu.org>2018-03-09 23:24:34 +0100
commit464f5447396fcec9b43f7eab71d5d42b522a157f (patch)
tree5d6eb998c752a1b375afae9c36df84dcb079f889 /gnu/packages/autotools.scm
parentab9ad138025bdc01e286044e5de20bf03ad1c3b9 (diff)
downloadguix-patches-464f5447396fcec9b43f7eab71d5d42b522a157f.tar
guix-patches-464f5447396fcec9b43f7eab71d5d42b522a157f.tar.gz
gnu: 'autoconf-wrapper' is no longer a procedure.
Fixes <https://bugs.gnu.org/30710>. Suggested by Björn Höfling <bjoern.hoefling@bjoernhoefling.de>. * gnu/packages/autotools.scm (autoconf-wrapper): Rename to... (make-autoconf-wrapper): ... this. Add 'properties' field. (autoconf-wrapper): New variable. * gnu/packages/gnunet.scm (guile-gnunet): Adjust accordingly. * gnu/packages/gnupg.scm (signing-party): Likewise. * gnu/packages/guile.scm (guile-ics, guile-bash): Likewise. * gnu/packages/libevent.scm (libuv): Likewise. * gnu/packages/logging.scm (glog): Likewise. * gnu/packages/mail.scm (libetpan): Likewise. * gnu/packages/mate.scm (mate-icon-theme-faenza) (mate-screensaver): Likewise. * gnu/packages/package-management.scm (guix): Likewise. * gnu/packages/sawfish.scm (librep): Likewise. * gnu/packages/video.scm (motion): Likewise. * gnu/packages/zile.scm (zile-on-guile): Likewise.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 846e318aa1..33addc11a7 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -124,8 +124,8 @@ know anything about Autoconf or M4.")
(string-append "--build=" build)))))))))))
-(define* (autoconf-wrapper #:optional (autoconf autoconf))
- "Return an wrapper around AUTOCONF that generates `configure' scripts that
+(define (make-autoconf-wrapper autoconf)
+ "Return a wrapper around AUTOCONF that generates `configure' scripts that
use our own Bash instead of /bin/sh in shebangs. For that reason, it should
only be used internally---users should not end up distributing `configure'
files with a system-specific shebang."
@@ -191,7 +191,13 @@ exec ~a --no-auto-compile \"$0\" \"$@\"
(patch-shebang "configure"))
(exit (status:exit-val result))))
port)))
- (chmod (string-append bin "/autoconf") #o555)))))))
+ (chmod (string-append bin "/autoconf") #o555)))))
+
+ ;; Do not show it in the UI since it's meant for internal use.
+ (properties '((hidden? . #t)))))
+
+(define-public autoconf-wrapper
+ (make-autoconf-wrapper autoconf))
(define-public autoconf-archive
(package
@@ -253,7 +259,7 @@ output is indexed in many ways to simplify browsing.")
(search-patches "automake-skip-amhello-tests.patch"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,(autoconf-wrapper))
+ `(("autoconf" ,autoconf-wrapper)
("perl" ,perl)))
(native-search-paths
(list (search-path-specification
@@ -348,7 +354,7 @@ Makefile, simplifying the entire process for the developer.")
("perl" ,perl)
("help2man" ,help2man) ;because we modify ltmain.sh
("automake" ,automake) ;some tests rely on 'aclocal'
- ("autoconf" ,(autoconf-wrapper)))) ;others on 'autom4te'
+ ("autoconf" ,autoconf-wrapper))) ;others on 'autom4te'
(arguments
`(;; Libltdl is provided as a separate package, so don't install it here.