summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-05-27 14:51:57 +0200
committerLudovic Courtès <ludo@gnu.org>2014-05-27 22:28:34 +0200
commit2a7050abf8ae27d6ee929426cadd3889be611ff8 (patch)
treea7941f05a514928dfd5c2ff7e913fd91317d511e /gnu/packages/autotools.scm
parent33dcd2a80410d9dbd9b4428ed6a7ef59cd1b0493 (diff)
downloadguix-patches-2a7050abf8ae27d6ee929426cadd3889be611ff8.tar
guix-patches-2a7050abf8ae27d6ee929426cadd3889be611ff8.tar.gz
gnu: Add Autoconf 2.64.
* gnu/packages/autotools.scm (autoconf-2.64): New variable.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index bd38f2a901..db1db45fc1 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -74,6 +74,20 @@ know anything about Autoconf or M4.")
(base32
"1fjm21k2na07f3vasf288a0zx66lbv0hd3l9bvv3q8p62s3pg569"))))))
+(define-public autoconf-2.64
+ ;; As of GDB 7.8, GDB is still developed using this version of Autoconf.
+ (package (inherit autoconf)
+ (version "2.64")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/autoconf/autoconf-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0j3jdjpf5ly39dlp0bg70h72nzqr059k0x8iqxvaxf106chpgn9j"))))))
+
+
(define* (autoconf-wrapper #:optional (autoconf autoconf))
"Return an wrapper around AUTOCONF that generates `configure' scripts that
use our own Bash instead of /bin/sh in shebangs. For that reason, it should