summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-27 00:21:10 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-27 00:21:10 +0100
commit20586ffdc746b17f8208e77852752e99bf5bee55 (patch)
treed527db415b0b16da72baa403bdfc58fe3500cc83 /gnu/packages/autotools.scm
parent18af6870370226b4d502d7372844e7f2aded5887 (diff)
downloadguix-patches-20586ffdc746b17f8208e77852752e99bf5bee55.tar
guix-patches-20586ffdc746b17f8208e77852752e99bf5bee55.tar.gz
gnu: Automake: Remove version 1.16.1.
* gnu/packages/autotools.scm (automake): Update to 1.16.2. [arguments]: Add phase "skip-test". (automake-1.16.2): Remove variable.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm39
1 files changed, 11 insertions, 28 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index faf26079b5..99ca52730e 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -250,14 +250,14 @@ output is indexed in many ways to simplify browsing.")
(define-public automake
(package
(name "automake")
- (version "1.16.1")
+ (version "1.16.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/automake/automake-"
version ".tar.xz"))
(sha256
(base32
- "08g979ficj18i1w6w5219bgmns7czr03iadf20mk3lrzl8wbn1ax"))
+ "1l7dkqbsmbf94ax29jj1jf6a0r6ikc8jybg1p5m0c3ki7pg5ki6c"))
(patches
(search-patches "automake-skip-amhello-tests.patch"))))
(build-system gnu-build-system)
@@ -289,6 +289,15 @@ output is indexed in many ways to simplify browsing.")
(setenv "CONFIG_SHELL" sh)
#t)))
+ (add-before 'check 'skip-test
+ (lambda _
+ ;; This test requires 'etags' and fails if it's missing.
+ ;; Skip it.
+ (substitute* "t/tags-lisp-space.sh"
+ (("^required.*" all)
+ (string-append "exit 77\n" all "\n")))
+ #t))
+
;; Files like `install-sh', `mdate.sh', etc. must use
;; #!/bin/sh, otherwise users could leak erroneous shebangs
;; in the wild. See <http://bugs.gnu.org/14201> for an
@@ -325,32 +334,6 @@ intuitive format and then Automake works with Autoconf to produce a robust
Makefile, simplifying the entire process for the developer.")
(license gpl2+))) ; some files are under GPLv3+
-(define-public automake-1.16.2
- (package
- (inherit automake)
- (version "1.16.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/automake/automake-"
- version ".tar.xz"))
- (sha256
- (base32
- "1l7dkqbsmbf94ax29jj1jf6a0r6ikc8jybg1p5m0c3ki7pg5ki6c"))
- (patches
- (search-patches "automake-skip-amhello-tests.patch"))))
- (arguments
- (substitute-keyword-arguments (package-arguments automake)
- ((#:phases phases '%standard-phases)
- `(modify-phases ,phases
- (add-before 'check 'skip-test
- (lambda _
- ;; This test requires 'etags' and fails if it's missing.
- ;; Skip it.
- (substitute* "t/tags-lisp-space.sh"
- (("^required.*" all)
- (string-append "exit 77\n" all "\n")))
- #t))))))))
-
(define-public libtool
(package
(name "libtool")