summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-02-16 10:56:34 -0500
committerMark H Weaver <mhw@netris.org>2015-02-16 10:56:34 -0500
commit192c6f966fd7e7ecf3b828baee0da9ebc2026471 (patch)
tree2e31dc4e1f74f9b0527e05209a2b065f23e784f6 /gnu/packages/autotools.scm
parentda466f7ff63e34aca271e603090f25ba471f009e (diff)
downloadguix-patches-192c6f966fd7e7ecf3b828baee0da9ebc2026471.tar
guix-patches-192c6f966fd7e7ecf3b828baee0da9ebc2026471.tar.gz
gnu: libtool and libltdl: Update to 2.4.6.
* gnu/packages/autotools.scm (libtool, libltdl): Update to 2.4.6. * gnu/packages/patches/libtool-skip-tests.patch: Adapt to 2.4.6.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 7f20b262f8..4b5cbb6dfd 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -238,14 +239,14 @@ Makefile, simplifying the entire process for the developer.")
(define-public libtool
(package
(name "libtool")
- (version "2.4.5")
+ (version "2.4.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libtool/libtool-"
version ".tar.xz"))
(sha256
(base32
- "0zhphv4n9bdd6sz66lqfrfqcsnv89mg2bykgi5w9401va4vc3al4"))
+ "0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))
(patches
(list (search-patch "libtool-skip-tests.patch")))))
(build-system gnu-build-system)
@@ -295,14 +296,14 @@ complexity of working with shared libraries across platforms.")
;; Libtool's extensive test suite isn't run.
(package
(name "libltdl")
- (version "2.4.4")
+ (version "2.4.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libtool/libtool-"
version ".tar.xz"))
(sha256
(base32
- "0v3zq08qxv7k5067mpqrkjkjl3wphhg06i696mka90mzadc5nad8"))
+ "0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))
(patches
(list (search-patch "libtool-skip-tests.patch")))))
(build-system gnu-build-system)