summaryrefslogtreecommitdiff
path: root/gnu/packages/autogen.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2013-10-14 12:55:53 -0500
committerLudovic Courtès <ludo@gnu.org>2013-10-16 00:12:27 +0200
commitd911258976690671d3b3ffe93994a6c5e2d72eed (patch)
tree6cb096d0a9b1802e31b076324922c3d1543deb73 /gnu/packages/autogen.scm
parentdfb52abbd60876de250f04fc5c64b3c85082cba6 (diff)
downloadguix-patches-d911258976690671d3b3ffe93994a6c5e2d72eed.tar
guix-patches-d911258976690671d3b3ffe93994a6c5e2d72eed.tar.gz
gnu: Add autogen package
* gnu/package/autogen.scm: New file * gnu-system.am: Add it Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/autogen.scm')
-rw-r--r--gnu/packages/autogen.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/autogen.scm b/gnu/packages/autogen.scm
new file mode 100644
index 0000000000..3109c2bf0b
--- /dev/null
+++ b/gnu/packages/autogen.scm
@@ -0,0 +1,63 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages autogen)
+ #:use-module (guix packages)
+ #:use-module (guix licenses)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages which)
+ #:use-module (gnu packages guile))
+
+(define-public autogen
+ (package
+ (name "autogen")
+ (version "5.18.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/autogen/rel"
+ version "/autogen-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0k0gkr5inr9wb3ws30q6bbiqg3qm3ryvl9cznym2xis4lm216d53"))))
+ (build-system gnu-build-system)
+ (inputs `(("which" ,which)
+ ("guile" ,guile-2.0)))
+ (arguments
+ '(#:phases (alist-cons-before
+ 'patch-source-shebangs 'patch-test-scripts
+ (lambda _
+ (let ((sh (which "sh")))
+ (substitute*
+ (append (find-files "agen5/test" "\\.test$")
+ (find-files "autoopts/test" "\\.(test|in)$"))
+ (("/bin/sh") sh)
+ (("/usr/bin/tr") "tr"))))
+ %standard-phases)))
+ (home-page "http://www.gnu.org/software/autogen/")
+ (synopsis "Automated program generator")
+ (description
+ "AutoGen is a program to ease the maintenance of programs that contain
+large amounts of repetitive text. It automates the construction of these
+sections of the code, simplifying the task of keeping the text in sync. It
+also includes an add-on package called AutoOpts, which is specialized for the
+maintenance and documentation of program options.")
+ (license gpl3+)))