summaryrefslogtreecommitdiff
path: root/gnu/packages/authentication.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-31 16:11:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-09 17:59:34 +0200
commit6bbbdb1a34607690ca8413f29bb7bf5cacae2bcc (patch)
treee8990651a04b7a03a4638d9284a7e6cff6094fa8 /gnu/packages/authentication.scm
parent0171019418435888afb6024d04702683482d0294 (diff)
downloadguix-patches-6bbbdb1a34607690ca8413f29bb7bf5cacae2bcc.tar
guix-patches-6bbbdb1a34607690ca8413f29bb7bf5cacae2bcc.tar.gz
gnu: oath-toolkit: Fix FTBFS with Glibc >= 2.28.
* gnu/packages/patches/oath-toolkit-glibc-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/authentication.scm (oath-toolkit)[source](patches): New field.
Diffstat (limited to 'gnu/packages/authentication.scm')
-rw-r--r--gnu/packages/authentication.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/authentication.scm b/gnu/packages/authentication.scm
index a58eac9890..68a6459828 100644
--- a/gnu/packages/authentication.scm
+++ b/gnu/packages/authentication.scm
@@ -17,6 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages authentication)
+ #:use-module (gnu packages)
#:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
#:use-module (guix build-system gnu)
@@ -35,6 +36,7 @@
(method url-fetch)
(uri (string-append "https://download.savannah.nongnu.org/releases/"
name "/" name "-" version ".tar.gz"))
+ (patches (search-patches "oath-toolkit-glibc-compat.patch"))
(sha256
(base32 "182ah8vfbg0yhv6mh1b6ap944d0na6x7lpfkwkmzb6jl9gx4cd5h"))))
(build-system gnu-build-system)