summaryrefslogtreecommitdiff
path: root/gnu/packages/augeas.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-21 16:03:26 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-02-16 14:41:25 +0100
commit469d6589e35939c50b9ff04e6c7b77fad82389cf (patch)
tree651d05990c3d821951bab94266cb542dcdeb9a4c /gnu/packages/augeas.scm
parentc5a6e33b5659925f8c56d93ee97e846ef2c42d4b (diff)
downloadguix-patches-469d6589e35939c50b9ff04e6c7b77fad82389cf.tar
guix-patches-469d6589e35939c50b9ff04e6c7b77fad82389cf.tar.gz
gnu: Add Augeas.
* gnu/packages/augeas.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/augeas.scm')
-rw-r--r--gnu/packages/augeas.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/augeas.scm b/gnu/packages/augeas.scm
new file mode 100644
index 0000000000..95b96ca25c
--- /dev/null
+++ b/gnu/packages/augeas.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages augeas)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix utils)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages readline)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xml))
+
+(define-public augeas
+ (package
+ (name "augeas")
+ (version "1.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.augeas.net/augeas-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0c2vncn0afmgwggnqa5s5z7m3zbcc66bi8v9m1h9w0i9q9xax7v5"))))
+ (build-system gnu-build-system)
+ ;; Marked as "required" in augeas.pc
+ (propagated-inputs
+ `(("libxml2" ,libxml2)))
+ (inputs
+ `(("readline" ,readline)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://augeas.net/")
+ (synopsis "Edit configuration files programmatically")
+ (description
+ "Augeas is a library and command line tool for programmatically editing
+configuration files in a controlled manner. Augeas exposes a tree of all
+configuration settings and a simple local API for manipulating the tree.
+Augeas then modifies underlying configuration files according to the changes
+that have been made to the tree; it does as little modeling of configurations
+as possible, and focuses exclusivley on transforming the tree-oriented syntax
+of its public API to the myriad syntaxes of individual configuration files.")
+ (license license:lgpl2.1+)))