summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-11-24 06:33:46 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2016-11-24 06:34:37 +0100
commitc50f2af9f800ae1b24e7b245b4a2ab137b18a664 (patch)
treef7d045d1ea13b8c279cd8e20188fba781a05f28a /gnu/packages/audio.scm
parent2df984f2787917168afc3eda92817c77dec5bddc (diff)
downloadguix-patches-c50f2af9f800ae1b24e7b245b4a2ab137b18a664.tar
guix-patches-c50f2af9f800ae1b24e7b245b4a2ab137b18a664.tar.gz
gnu: ir: Use archived tarball and home page.
* gnu/packages/audio.scm (ir)[source]: Use a list of archive mirrors. [home-page]: Link to an Internet Archive snapshot.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 2ecc9a570d..b535448af1 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1178,9 +1178,15 @@ well suited to all musical instruments and vocals.")
(version "1.3.2")
(source (origin
(method url-fetch)
- (uri (string-append
- "http://factorial.hu/system/files/ir.lv2-"
- version ".tar.gz"))
+ ;; The original home-page is gone. Download the tarball from an
+ ;; archive mirror instead.
+ (uri (list (string-append
+ "https://web.archive.org/web/20150803095032/"
+ "http://factorial.hu/system/files/ir.lv2-"
+ version ".tar.gz")
+ (string-append
+ "https://mirrors.kernel.org/gentoo/distfiles/ir.lv2-"
+ version ".tar.gz")))
(sha256
(base32
"1jh2z01l9m4ar7yz0n911df07dygc7n4cl59p7qdjbh0nvkm747g"))))
@@ -1203,7 +1209,9 @@ well suited to all musical instruments and vocals.")
(list (search-path-specification
(variable "LV2_PATH")
(files '("lib/lv2")))))
- (home-page "http://factorial.hu/plugins/lv2/ir")
+ ;; Link to an archived copy of the home-page since the original is gone.
+ (home-page (string-append "https://web.archive.org/web/20150803095032/"
+ "http://factorial.hu/plugins/lv2/ir"))
(synopsis "LV2 convolution reverb")
(description
"IR is a low-latency, real-time, high performance signal convolver