summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-09-11 08:23:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 08:24:02 +0200
commitbf592ef506e1db0340dc11faa0514fe80793e6d6 (patch)
tree56992fcbb1967083077666365e857d11511e2588 /gnu/packages/audio.scm
parent9e4ef763ea8fa9feac1c2f01220d67c50bcb6ad1 (diff)
downloadguix-patches-bf592ef506e1db0340dc11faa0514fe80793e6d6.tar
guix-patches-bf592ef506e1db0340dc11faa0514fe80793e6d6.tar.gz
gnu: guitarix: Update to 0.41.0.
* gnu/packages/audio.scm (guitarix): Update to 0.41.0. [inputs]: Remove gtkmm-2 and gtk+-2; add gtkmm and gtk+. [native-inputs]: Add sassc. [arguments]: Do not use Python 2; remove phase "fix-boost-includes".
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm28
1 files changed, 8 insertions, 20 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8ff80b889e..43221788e1 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -108,6 +108,7 @@
#:use-module (gnu packages valgrind)
#:use-module (gnu packages video)
#:use-module (gnu packages vim) ;xxd
+ #:use-module (gnu packages web)
#:use-module (gnu packages webkit)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xiph)
@@ -1822,7 +1823,7 @@ patches that can be used with softsynths such as Timidity and WildMidi.")
(define-public guitarix
(package
(name "guitarix")
- (version "0.38.1")
+ (version "0.41.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1830,28 +1831,14 @@ patches that can be used with softsynths such as Timidity and WildMidi.")
version ".tar.xz"))
(sha256
(base32
- "0bw7xnrx062nwb1bfj9x660h7069ncmz77szcs8icpqxrvhs7z80"))))
+ "0qsfbyrrpb3bbdyq68k28mjql7kglxh8nqcw9jvja28x6x9ik5a0"))))
(build-system waf-build-system)
(arguments
`(#:tests? #f ; no "check" target
- #:python ,python-2
#:configure-flags
(list
;; Add the output lib directory to the RUNPATH.
- (string-append "--ldflags=-Wl,-rpath=" %output "/lib"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-boost-includes
- (lambda _
- (substitute* "src/headers/gx_internal_plugins.h"
- (("namespace gx_jack" m)
- (string-append "#include <boost/noncopyable.hpp>\n" m)))
- (substitute* '("src/headers/gx_system.h"
- "src/headers/gx_parameter.h"
- "src/headers/gx_json.h")
- (("namespace gx_system" m)
- (string-append "#include <boost/noncopyable.hpp>\n" m)))
- #t)))))
+ (string-append "--ldflags=-Wl,-rpath=" %output "/lib"))))
(inputs
`(("libsndfile" ,libsndfile)
("boost" ,boost)
@@ -1862,8 +1849,8 @@ patches that can be used with softsynths such as Timidity and WildMidi.")
("lilv" ,lilv)
("ladspa" ,ladspa)
("jack" ,jack-1)
- ("gtkmm" ,gtkmm-2)
- ("gtk+" ,gtk+-2)
+ ("gtkmm" ,gtkmm)
+ ("gtk+" ,gtk+)
("fftwf" ,fftwf)
("lrdf" ,lrdf)
("zita-resampler" ,zita-resampler)
@@ -1873,7 +1860,8 @@ patches that can be used with softsynths such as Timidity and WildMidi.")
("faust" ,faust)
("intltool" ,intltool)
("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("sassc" ,sassc)))
(native-search-paths
(list (search-path-specification
(variable "LV2_PATH")