summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-02-25 09:45:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-02-27 12:27:21 +0100
commita91d72e23acf87899bb57d618f2fd8c79dcea1b3 (patch)
tree58dde7f6028093e17eb2fffd495e5cb702e40b39 /gnu/packages/audio.scm
parentb460a99890437e704aa92bd2d93a910d6a1bd45e (diff)
downloadguix-patches-a91d72e23acf87899bb57d618f2fd8c79dcea1b3.tar
guix-patches-a91d72e23acf87899bb57d618f2fd8c79dcea1b3.tar.gz
gnu: Add pyliblo.
* gnu/packages/audio.scm (python-pyliblo, python2-pyliblo): New variables.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 4c4322d872..865394a726 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -30,6 +30,7 @@
#:use-module (guix build-system waf)
#:use-module (guix build-system trivial)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
@@ -946,6 +947,34 @@ essential distortions.")
implementation of the Open Sound Control (OSC) protocol.")
(license license:lgpl2.1+)))
+(define-public python-pyliblo
+ (package
+ (name "python-pyliblo")
+ (version "0.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://das.nasophon.de/download/pyliblo-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "13vry6xhxm7adnbyj28w1kpwrh0kf7nw83cz1yq74wl21faz2rzw"))))
+ (build-system python-build-system)
+ (arguments `(#:tests? #f)) ;no tests
+ (inputs
+ `(("python-cython" ,python-cython)
+ ("liblo" ,liblo)))
+ (home-page "http://das.nasophon.de/pyliblo/")
+ (synopsis "Python bindings for liblo")
+ (description
+ "Pyliblo is a Python wrapper for the liblo Open Sound Control (OSC)
+library. It supports almost the complete functionality of liblo, allowing you
+to send and receive OSC messages using a nice and simple Python API. Also
+included are the command line utilities @code{send_osc} and @code{dump_osc}.")
+ (license license:lgpl2.1+)))
+
+(define-public python2-pyliblo
+ (package-with-python2 python-pyliblo))
+
(define-public lilv
(package
(name "lilv")