summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-01 00:08:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-01 00:08:27 +0100
commit77fc94ef1fbd2f43706a4a0374cc07265629bfa3 (patch)
tree403cebb2f4d557fdc3dd1f24d25feea2832977c9 /gnu/packages/audio.scm
parentd348439bb881905fb938b0e7b0bf66cd797901ef (diff)
downloadguix-patches-77fc94ef1fbd2f43706a4a0374cc07265629bfa3.tar
guix-patches-77fc94ef1fbd2f43706a4a0374cc07265629bfa3.tar.gz
gnu: Add tao-synth.
* gnu/packages/audio.scm (tao-synth): New variable.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index aba2f9b8b6..e10ee31b12 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1299,6 +1299,37 @@ playing instruments and a C++ API for those who would like to use it as an
object library.")
(license license:gpl2+)))
+(define-public tao-synth
+ (let ((commit "f3aedd81efbc775574e591081b57ae1c08427064")
+ (revision "1"))
+ (package
+ (name "tao-synth")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lucasw/tao_synth")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jds2l3cb96b02jxd7lmrjjl9s7mylnrvg6fpw0j8c141bk8vyg3"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #false)) ;there are no tests
+ (inputs
+ (list glfw freeglut))
+ (native-inputs
+ (list gcc-7))
+ (home-page "https://github.com/lucasw/tao_synth")
+ (synopsis "Sound synthesis with physical models")
+ (description "Tao is a software package for sound synthesis using physical
+models. It provides a virtual acoustic material constructed from masses and
+springs which can be used as the basis for building quite complex virtual
+musical instruments. Tao comes with a synthesis language for creating and
+playing instruments and a C++ API for those who would like to use it as an
+object library.")
+ (license license:lgpl2.0+))))
+
(define-public csound
(package
(name "csound")