summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-01-05 08:08:44 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-01-05 17:30:14 +0300
commit7366d83191e4cdebc0fb81728f79a3d576fef73b (patch)
tree485198a4c4079e1be2cb68b1972837ab42ddf9b8 /gnu/packages/audio.scm
parenta8f753c293a4258c07126007b2e47d476b8a59e9 (diff)
downloadguix-patches-7366d83191e4cdebc0fb81728f79a3d576fef73b.tar
guix-patches-7366d83191e4cdebc0fb81728f79a3d576fef73b.tar.gz
gnu: Add swh-plugins.
* gnu/packages/audio.scm (swh-plugins): New variable.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index a26fbed461..acc443839f 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2016 ng0 <ng0@n0.is>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 okapi <okapi@firemail.cc>
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
@@ -722,6 +722,36 @@ performances. The plugins include a cellular automaton synthesizer, an
envelope follower, distortion effects, tape effects and more.")
(license license:gpl2+)))
+(define-public swh-plugins
+ (package
+ (name "swh-plugins")
+ (version "0.4.17")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/swh/ladspa.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1c98z2xxz9pgcb4dg99gz8qrylh5cnag0j18a52d88ifsy24isvq"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal) ;for autopoint
+ ("libtool" ,libtool)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("which" ,which)))
+ (inputs
+ `(("fftwf" ,fftwf)
+ ("perl-xml-parser" ,perl-xml-parser)))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/swh/ladspa/")
+ (synopsis "The SWH Plugins package for the LADSPA plugin system")
+ (description "This package provides Steve Harris's LADSPA plugins.")
+ (license license:gpl2+)))
+
(define-public swh-plugins-lv2
(package
(name "swh-plugins-lv2")