summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorFPS <mista.tapas@gmx.net>2019-11-01 14:35:49 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-03 19:33:47 +0100
commit6833c7a1b3752a28737541bbbdcb357888512bfe (patch)
tree87aa744c299c121937a0f26c5b4dd89f4a21cd13 /gnu/packages/audio.scm
parent4e6568cedde4c0a90b39c1530bf303a78e124972 (diff)
downloadguix-patches-6833c7a1b3752a28737541bbbdcb357888512bfe.tar
guix-patches-6833c7a1b3752a28737541bbbdcb357888512bfe.tar.gz
gnu: lilv: Enable python bindings.
* gnu/packages/audio.scm (lilv)[arguments]: Add #:configure-flags. Add phase to embed full path to liblilv-0.so. [native-inputs]: Add PYTHON. [home-page]: Follow redirect. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 88b5696a9b..28dbf06f3b 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1825,6 +1825,7 @@ included are the command line utilities @code{send_osc} and @code{dump_osc}.")
(build-system waf-build-system)
(arguments
`(#:tests? #f ; no check target
+ #:configure-flags (list "--bindings")
#:phases
(modify-phases %standard-phases
(add-before
@@ -1833,7 +1834,14 @@ included are the command line utilities @code{send_osc} and @code{dump_osc}.")
(setenv "LDFLAGS"
(string-append "-Wl,-rpath="
(assoc-ref outputs "out") "/lib"))
- #t)))))
+ #t))
+ (add-after 'unpack 'full-store-path-to-shared-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-directory-excursion "bindings/python"
+ (substitute* "lilv.py"
+ (("liblilv-0.so") (string-append (assoc-ref outputs "out")
+ "/lib/liblilv-0.so"))))
+ #t)))))
;; Required by lilv-0.pc.
(propagated-inputs
`(("lv2" ,lv2)
@@ -1841,8 +1849,9 @@ included are the command line utilities @code{send_osc} and @code{dump_osc}.")
("sord" ,sord)
("sratom" ,sratom)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "https://drobilla.net/software/lilv/")
+ `(("python" ,python)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://drobilla.net/software/lilv")
(synopsis "Library to simplify use of LV2 plugins in applications")
(description
"Lilv is a C library to make the use of LV2 plugins as simple as possible