summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorMike Rosset <mike.rosset@gmail.com>2020-09-15 01:33:23 -0700
committerAndreas Enge <andreas@enge.fr>2020-09-15 20:07:52 +0200
commit52139ce5b7f54fea930a4ae15815ecb75a3fbdb6 (patch)
tree3209ffb8ec18dc9ce29bb4182e2c2d7fea275c0b /gnu/packages/audio.scm
parentf5163902d7c3cfed5a97033f38e92d7158b19fa8 (diff)
downloadguix-patches-52139ce5b7f54fea930a4ae15815ecb75a3fbdb6.tar
guix-patches-52139ce5b7f54fea930a4ae15815ecb75a3fbdb6.tar.gz
gnu: jack-2: Update to 1.9.14.
* gnu/packages/audio.scm (jack-2): Update to 1.9.14. [arguments]: Add environment variable to phase 'set-linkflags. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 38ee4f8bcc..fb98777290 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2030,7 +2030,7 @@ synchronous execution of all clients, and low latency operation.")
(define-public jack-2
(package (inherit jack-1)
(name "jack2")
- (version "1.9.13")
+ (version "1.9.14")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/jackaudio/jack2/releases/"
@@ -2039,7 +2039,7 @@ synchronous execution of all clients, and low latency operation.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1d1d403jn4366mqig6g8ghr8057b3rn7gs26b5p3rkal34j20qw2"))))
+ "0z11hf55a6mi8h50hfz5wry9pshlwl4mzfwgslghdh40cwv342m2"))))
(build-system waf-build-system)
(arguments
`(#:tests? #f ; no check target
@@ -2049,6 +2049,10 @@ synchronous execution of all clients, and low latency operation.")
(modify-phases %standard-phases
(add-before 'configure 'set-linkflags
(lambda _
+ ;; Ensure -lstdc++ is the tail of LDFLAGS or the simdtests.cpp
+ ;; will not link with undefined reference to symbol
+ ;; '__gxx_personality_v0@@CXXABI_1.3'
+ (setenv "LDFLAGS" "-lstdc++")
;; Add $libdir to the RUNPATH of all the binaries.
(substitute* "wscript"
((".*CFLAGS.*-Wall.*" m)