summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-23 18:06:34 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-23 23:51:22 +0200
commit0e001b1f412d26937eb7cc616dab6b8a8b6beeee (patch)
tree25e03b32b89af2660eaa24411d814832323043ff /gnu/packages/audio.scm
parent9f38cdac5e17d71fc27848383d7ec29e4514cd4f (diff)
downloadguix-patches-0e001b1f412d26937eb7cc616dab6b8a8b6beeee.tar
guix-patches-0e001b1f412d26937eb7cc616dab6b8a8b6beeee.tar.gz
gnu: wavpack: Update to 5.3.2.
* gnu/packages/audio.scm (wavpack): Update to 5.3.2. [source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Replace the ‘bootstrap’ phase. [native-inputs]: Add autoconf, automake, and libtool.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm32
1 files changed, 23 insertions, 9 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index dfef3a81e7..20f9e1bfba 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2858,17 +2858,31 @@ stretching and pitch scaling of audio. This package contains the library.")
(define-public wavpack
(package
(name "wavpack")
- (version "5.3.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.wavpack.com/"
- "wavpack-" version ".tar.xz"))
- (sha256
- (base32
- "01r351ggha9pdfk7p601dlxac4ka1q89lgnb6zqk00zf1fd3fi5l"))))
+ (version "5.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dbry/WavPack")
+ (commit "e4e8d191e8dd74cbdbeaef3232c16a7ef517e68d")))
+ (sha256
+ (base32 "1zj8svk6giy1abq3940sz32ygz7zldppxl47852zgn5wfm3l2spx"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")))
+ '(#:configure-flags
+ (list "--disable-static")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ ;; Running ./autogen.sh would cause premature configuration.
+ (lambda _
+ (invoke "autoreconf" "-vif")
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
(home-page "http://www.wavpack.com/")
(synopsis "Hybrid lossless audio codec")
(description