summaryrefslogtreecommitdiff
path: root/gnu/packages/attr.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-01 16:05:04 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-01 16:31:52 +0100
commit1130929acfff30b3f179e6bb949b1b7d78b85b69 (patch)
treef7890104848105e0bc336a99f507d439c4e40537 /gnu/packages/attr.scm
parente02671939bcc4a38e13f68f58d4cb531150dde81 (diff)
downloadguix-patches-1130929acfff30b3f179e6bb949b1b7d78b85b69.tar
guix-patches-1130929acfff30b3f179e6bb949b1b7d78b85b69.tar.gz
gnu: attr: Update to 2.4.48.
* gnu/packages/attr.scm (attr): Update to 2.4.48. [source](uri): Adjust for renamed tarball. [arguments]: Remove obsolete phases. [license]: Remove GPL2+ (see upstream commit 0fb61a4d20).
Diffstat (limited to 'gnu/packages/attr.scm')
-rw-r--r--gnu/packages/attr.scm19
1 files changed, 5 insertions, 14 deletions
diff --git a/gnu/packages/attr.scm b/gnu/packages/attr.scm
index ff0a07aa67..3237376d40 100644
--- a/gnu/packages/attr.scm
+++ b/gnu/packages/attr.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2012, 2013, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,28 +30,18 @@
(define-public attr
(package
(name "attr")
- (version "2.4.47")
+ (version "2.4.48")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/attr/attr-"
- version ".src.tar.gz"))
+ version ".tar.gz"))
(sha256
(base32
- "0nd8y0m6awc9ahv0ciiwf8gy54c8d3j51pw9xg7f7cn579jjyxr5"))))
+ "1rr4adzwax4bzr2c00f06zcsljv5y6p9wymz1g89ww7cb2rp5bay"))))
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'configure 'patch-makefile-SHELL
- (lambda _
- (patch-makefile-SHELL "include/buildmacros")
- #t))
- (replace 'install
- (lambda _
- (invoke "make"
- "install"
- "install-lib"
- "install-dev")))
(replace 'check
(lambda* (#:key target #:allow-other-keys)
;; Use the right shell.
@@ -80,4 +71,4 @@
(synopsis "Library and tools for manipulating extended attributes")
(description
"Portable library and tools for manipulating extended attributes.")
- (license (list gpl2+ lgpl2.1+))))
+ (license lgpl2.1+)))