summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorpaladhammika <paladhammika@protonmail.com>2022-01-04 10:42:24 -0500
committerLudovic Courtès <ludo@gnu.org>2022-01-08 23:27:42 +0100
commitc487b05d5fd1f27f9515483f6ba5a86bad2a9f45 (patch)
tree1cfc1286288247f8cd847f0ba1cb5fbad25259ea /gnu/packages/astronomy.scm
parent1972cb0ea81c85b9bcada844267defaebdba7e99 (diff)
downloadguix-patches-c487b05d5fd1f27f9515483f6ba5a86bad2a9f45.tar
guix-patches-c487b05d5fd1f27f9515483f6ba5a86bad2a9f45.tar.gz
gnu: Add python-astral.
* gnu/packages/astronomy.scm (python-astral): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1f9eca9a44..a7a07fa3a8 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -57,6 +57,7 @@
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages time)
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
#:use-module (gnu packages wxwidgets)
@@ -704,6 +705,36 @@ much of the core functionality and some common tools needed for performing
astronomy and astrophysics.")
(license license:bsd-3)))
+(define-public python-astral
+ (package
+ (name "python-astral")
+ (version "2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "astral" version))
+ (sha256
+ (base32 "1gkggdibccmdy9glymw3kbrkzm6svvsg0lk56hhy92y4smkrj7g4"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "pytest")))))))
+ (native-inputs
+ (list python-freezegun python-setuptools-scm))
+ (propagated-inputs
+ (list python-dataclasses python-pytest python-pytz))
+ (home-page "https://github.com/sffjunkie/astral")
+ (synopsis "Calculations for the position of the sun and moon")
+ (description "Astral is a Python module that calculates times for various
+positions of the sun: dawn, sunrise, solar noon, sunset, dusk, solar
+elevation, solar azimuth, rahukaalam, and the phases of the moon.")
+ (license license:asl2.0)))
+
(define-public libnova
(package
(name "libnova")