summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-02-13 14:30:01 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-19 11:05:33 +0100
commitc1563fc116584cec517c9f5c866c661d3e7cec4e (patch)
tree7fea97fa3e99c339a7f5e662b9028dba6c654320 /gnu/packages/astronomy.scm
parent8fa76b836ddc651ff3ca3637af27a5c977af367d (diff)
downloadguix-patches-c1563fc116584cec517c9f5c866c661d3e7cec4e.tar
guix-patches-c1563fc116584cec517c9f5c866c661d3e7cec4e.tar.gz
gnu: Add qfits.
* gnu/packages/astronomy.scm (qfits): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c239a02f3b..9f6b102af7 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -94,6 +94,25 @@ in FITS files.")
(license (license:non-copyleft "file://License.txt"
"See License.txt in the distribution."))))
+(define-public qfits
+ (package
+ (name "qfits")
+ (version "6.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "ftp://ftp.eso.org/pub/qfits/qfits-" version ".tar.gz"))
+ (sha256
+ (base32 "0m2b21mim3a7wgfg3ph2w5hv7mdvr03jmmhzipc0wcahijglcw9j"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.eso.org/sci/software/eclipse/qfits/")
+ (synopsis "C library offering access to astronomical FITS files")
+ (description
+ "@code{qfits} is a C library giving access to FITS file internals, both
+for reading and writing.")
+ (license license:gpl2+)))
+
(define-public eye
(package
(name "eye")