summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-01-24 11:16:36 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-01-25 17:59:02 +0100
commitb2d6f127c24787df00bffd918fa879842f933817 (patch)
treed067fb80cbe860eda93f8eb3eb6e9af7edc04150 /gnu/packages/astronomy.scm
parent906155e437c9513462f19baac6e88b976f42b358 (diff)
downloadguix-patches-b2d6f127c24787df00bffd918fa879842f933817.tar
guix-patches-b2d6f127c24787df00bffd918fa879842f933817.tar.gz
gnu: Add sextractor.
* gnu/packages/astronomy.scm (sextractor): New variable. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 6323f3eb48..0e1a55481f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -158,6 +158,52 @@ header.")
programs for the manipulation and analysis of astronomical data.")
(license license:gpl3+)))
+(define-public sextractor
+ (package
+ (name "sextractor")
+ (version "2.25.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/sextractor")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q69n3nyal57h3ik2xirwzrxzljrwy9ivwraxzv9566vi3n4z5mw"))))
+ (build-system gnu-build-system)
+ ;; NOTE: (Sharlatan-20210124T103117+0000): Building with `atlas' is failing
+ ;; due to missing shared library which required on configure phase. Switch
+ ;; build to use `openblas' instead. It requires FFTW with single precision
+ ;; `fftwf'.
+ (arguments
+ `(#:configure-flags
+ (list
+ "--enable-openblas"
+ (string-append
+ "--with-openblas-libdir=" (assoc-ref %build-inputs "openblas") "/lib")
+ (string-append
+ "--with-openblas-incdir=" (assoc-ref %build-inputs "openblas") "/include")
+ (string-append
+ "--with-fftw-libdir=" (assoc-ref %build-inputs "fftw") "/lib")
+ (string-append
+ "--with-fftw-incdir=" (assoc-ref %build-inputs "fftw") "/include"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (inputs
+ `(("openblas" ,openblas)
+ ("fftw" ,fftwf)))
+ (home-page "http://www.astromatic.net/software/sextractor")
+ (synopsis "Extract catalogs of sources from astronomical images")
+ (description
+ "SExtractor is a program that builds a catalogue of objects from an
+astronomical image. Although it is particularly oriented towards reduction of
+large scale galaxy-survey data, it can perform reasonably well on moderately
+crowded star fields.")
+ (license license:gpl3+)))
+
(define-public stellarium
(package
(name "stellarium")