summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-01-10 19:29:33 -0500
committerLeo Famulari <leo@famulari.name>2019-01-11 17:07:55 -0500
commit81c64748bad51c7449eea8bab4953ecb89d02fa2 (patch)
treea4551939bdf9b07b33d9248bf0e9757afbba76a2 /gnu/packages/astronomy.scm
parent1ac0c1b8990317c0675df2d84b68ce4c85b18104 (diff)
downloadguix-patches-81c64748bad51c7449eea8bab4953ecb89d02fa2.tar
guix-patches-81c64748bad51c7449eea8bab4953ecb89d02fa2.tar.gz
gnu: Stellarium: Update to 0.18.3.
* gnu/packages/astronomy.scm (stellarium): Update to 0.18.3. [arguments]: Skip a broken test.
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 7e6a56c545..2813062e95 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -131,7 +131,7 @@ programs for the manipulation and analysis of astronomical data.")
(define-public stellarium
(package
(name "stellarium")
- (version "0.18.1")
+ (version "0.18.3")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/Stellarium/" name
@@ -139,7 +139,7 @@ programs for the manipulation and analysis of astronomical data.")
"/" name "-" version ".tar.gz"))
(sha256
(base32
- "0vjkwrjy22b4wdjkafm63pmb0fck14ffnylpq8xr91ywycw4blrq"))))
+ "1mm8rjcb8j56m3kfigpix5vxviw1616kvl9ws2s3s5gdyngljrc3"))))
(build-system cmake-build-system)
(inputs
`(("qtbase" ,qtbase)
@@ -161,6 +161,13 @@ programs for the manipulation and analysis of astronomical data.")
(assoc-ref %build-inputs "qtserialport")
"/include/qt5"))
#:phases (modify-phases %standard-phases
+ ;; Skip a test that assumes Stellarium is "installed":
+ ;; https://bugs.gentoo.org/674472
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ (substitute* "src/tests/testEphemeris.cpp"
+ (("ifndef Q_OS_WIN") "if 0"))
+ #t))
(add-before 'check 'set-offscreen-display
(lambda _
;; make Qt render "offscreen", required for tests