summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorAmar Singh <nly@disroot.org>2019-06-13 22:53:22 +0530
committerLudovic Courtès <ludo@gnu.org>2019-06-26 15:59:58 +0200
commit67d24b15ca634ac4820f9b7b410a6a2980bdab4a (patch)
treee6fe5839c59d06d4e9ad45b948608a61c82b3e2b /gnu/packages/astronomy.scm
parentca310f65c56d255ecd9e47feb9c4a67d18b969d0 (diff)
downloadguix-patches-67d24b15ca634ac4820f9b7b410a6a2980bdab4a.tar
guix-patches-67d24b15ca634ac4820f9b7b410a6a2980bdab4a.tar.gz
gnu: Add celestia-gtk.
* gnu/packages/astronomy.scm (celestia-gtk): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 59fa11bfda..81c7481e0b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -38,9 +38,12 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages gl)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages maths)
#:use-module (guix build-system cmake)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module (srfi srfi-1))
(define-public cfitsio
(package
@@ -234,3 +237,15 @@ object in the expandable database and view it from any point in space and
time. The position and movement of solar system objects is calculated
accurately in real time at any rate desired.")
(license license:gpl2+))))
+
+(define-public celestia-gtk
+ (package
+ (inherit celestia)
+ (name "celestia-gtk")
+ (inputs
+ (append (alist-delete "freeglut" (package-inputs celestia))
+ `(("gtk2" ,gtk+-2)
+ ("gtkglext" ,gtkglext))))
+ (arguments
+ `(#:configure-flags '("-DENABLE_GTK=ON" "-DENABLE_QT=OFF")
+ #:tests? #f))))