summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-06 04:02:15 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-06 06:12:21 +0200
commit60b0c2522201681cf33ac359dc57f0f0d73ef6ed (patch)
tree87590f58f620bb25b66b2927c450d279e65a7e69 /gnu/packages/astronomy.scm
parent4f12e5cc7cedca15e46d30e96fb89f7c63eb43e5 (diff)
downloadguix-patches-60b0c2522201681cf33ac359dc57f0f0d73ef6ed.tar
guix-patches-60b0c2522201681cf33ac359dc57f0f0d73ef6ed.tar.gz
gnu: wcslib: Fix build.
* gnu/packages/astronomy.scm (wcslib)[arguments]: Skip the default ‘install-license-files’ phase. Don't build or test in parallel.
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 8cf9d9e4a5..327e46e995 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -81,12 +81,17 @@ in FITS files.")
`(("cfitsio" ,cfitsio)))
(build-system gnu-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-before 'configure 'patch-/bin/sh
- (lambda _
- (substitute* "makedefs.in"
- (("/bin/sh") "sh"))
- #t)))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-/bin/sh
+ (lambda _
+ (substitute* "makedefs.in"
+ (("/bin/sh") "sh"))
+ #t))
+ (delete 'install-license-files)) ; installed by ‘make install’
+ ;; Both the build and tests fail randomly when run in parallel.
+ #:parallel-build? #f
+ #:parallel-tests? #f))
(home-page "https://www.atnf.csiro.au/people/mcalabre/WCS")
(synopsis "Library which implements the FITS WCS standard")
(description "The FITS \"World Coordinate System\" (@dfn{WCS}) standard