summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2016-08-30 21:08:23 +0200
committerJohn Darrington <jmd@gnu.org>2016-08-31 06:17:07 +0200
commit2be83f6e8d3678253a1f9c8b0e5fa264ebf81e2a (patch)
tree6e5cc5adabcbee2534065ba01a9228cca14b8879 /gnu/packages/astronomy.scm
parent82e4557d5650b99192bef55b8c518e6444816282 (diff)
downloadguix-patches-2be83f6e8d3678253a1f9c8b0e5fa264ebf81e2a.tar
guix-patches-2be83f6e8d3678253a1f9c8b0e5fa264ebf81e2a.tar.gz
gnu: Add wcslib
* gnu/packages/astronomy.scm (wcslib): New variable.
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index ba1556882d..996829397d 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -51,3 +51,30 @@ provides many advanced features for manipulating and filtering the information
in FITS files.")
(license (license:non-copyleft "file://License.txt"
"See License.txt in the distribution."))))
+
+(define-public wcslib
+ (package
+ (name "wcslib")
+ (version "5.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "ftp://ftp.atnf.csiro.au/pub/software/wcslib/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32 "1s2nig327g4bimd9xshlk11ww09a7mrjmsbpdcd8smsmn2kl1glb"))))
+ (inputs
+ `(("cfitsio" ,cfitsio)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'patch-/bin/sh
+ (lambda _
+ (substitute* "makedefs.in"
+ (("/bin/sh") "sh")))))))
+ (home-page "http://www.atnf.csiro.au/people/mcalabre/WCS")
+ (synopsis "An implementation of the FITS WCS standard")
+ (description "The FITS \"World Coordinate System\" (WCS) standard defines
+keywords and usage that provide for the description of astronomical coordinate
+systems in a FITS image header.")
+ (license license:lgpl3+)))