summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-24 14:10:25 -0500
committerLeo Famulari <leo@famulari.name>2017-12-24 16:51:32 -0500
commit09c9fe4a77e93949cdb51ff0be330650aa1a0486 (patch)
tree7d4c46376e7d079513d59d9f651b2fb48d5c97aa /gnu/packages/astronomy.scm
parent66776562beedc3f47a1662aceb31c217390cdfdb (diff)
downloadguix-patches-09c9fe4a77e93949cdb51ff0be330650aa1a0486.tar
guix-patches-09c9fe4a77e93949cdb51ff0be330650aa1a0486.tar.gz
gnu: gnuastro: Update to 0.5.
* gnu/packages/astronomy.scm (gnuastro): Update to 0.5. [inputs]: Use the latest libjpeg. [arguments]: Remove an obselete option from #:configure-flags.
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a1f5bd1820..d21c093876 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -93,7 +93,7 @@ systems in a FITS image header.")
(define-public gnuastro
(package
(name "gnuastro")
- (version "0.4")
+ (version "0.5")
(source
(origin
(method url-fetch)
@@ -101,17 +101,13 @@ systems in a FITS image header.")
version ".tar.gz"))
(sha256
(base32
- "1n30zz4kg89ic5h30b7nrxp0bk0ls2m3xnfi81mja56bxxwpihrs"))))
+ "10lxzxyrf30hj3bqdgprvaj9phzdi816khjmr0vmjf8pmsr8bqqr"))))
(inputs
`(("cfitsio" ,cfitsio)
("gsl" ,gsl)
- ("libjpeg" ,libjpeg-8)
+ ("libjpeg" ,libjpeg)
("wcslib" ,wcslib)))
(build-system gnu-build-system)
- (arguments
- ;; Reduce the number of required type conversions by enabling arithmetic
- ;; with all the supported types.
- `(#:configure-flags '("--enable-bin-op-alltypes")))
(home-page "https://www.gnu.org/software/gnuastro/")
(synopsis "Astronomy utilities")
(description "The GNU Astronomy Utilities (Gnuastro) is a suite of