summaryrefslogtreecommitdiff
path: root/gnu/packages/assembly.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-04 17:41:36 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-04 17:41:36 +0100
commita351fc83694f436c3bff7cbdef09bd3cc91c74fc (patch)
tree646145378742a6943d7c4dda995fc0fb67f9db32 /gnu/packages/assembly.scm
parent80b63e670ef4fe1fd40a903bcd4ee47a11415bd9 (diff)
parentd1a5b20081c30da7503201df260cf20b8d0ba633 (diff)
downloadguix-patches-a351fc83694f436c3bff7cbdef09bd3cc91c74fc.tar
guix-patches-a351fc83694f436c3bff7cbdef09bd3cc91c74fc.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/assembly.scm')
-rw-r--r--gnu/packages/assembly.scm23
1 files changed, 15 insertions, 8 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 29ccf1f08a..fbc5cdd16f 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -34,24 +34,32 @@
(define-public nasm
(package
(name "nasm")
- (version "2.12.01")
+ (version "2.12.02")
(source (origin
(method url-fetch)
(uri (string-append "http://www.nasm.us/pub/nasm/releasebuilds/"
version "/" name "-" version ".tar.xz"))
(sha256
(base32
- "12bl6vc5sjp9nnhf0iwy6l27vq783y0rxrjpp8sy84h5cb7a3fwx"))
- (patches (search-patches "nasm-no-ps-pdf.patch"))))
+ "08a3ah791cl7xdyrlz33mwv4xzs08rxh0p902p3ypi5iq1h6p1jc"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl) ;for doc and test target
("texinfo" ,texinfo)))
(arguments
`(#:test-target "test"
- #:phases (modify-phases %standard-phases
- (add-after 'install 'install-info
- (lambda _
- (zero? (system* "make" "install_doc")))))))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'dont-build-ps-pdf-outputs
+ (lambda _
+ (substitute* "doc/Makefile.in"
+ (("info html nasmdoc.txt nasmdoc.ps nasmdoc.pdf")
+ "info html nasmdoc.txt")
+ (("nasmdoc.ps nasmdoc.pdf nasmdoc.txt \\$\\(INSTALLROOT\\)\\$\\(docdir\\)")
+ "nasmdoc.txt $(INSTALLROOT)$(docdir)"))
+ #t))
+ (add-after 'install 'install-info
+ (lambda _
+ (zero? (system* "make" "install_doc")))))))
(home-page "http://www.nasm.us/")
(synopsis "80x86 and x86-64 assembler")
(description
@@ -62,7 +70,6 @@ Windows32 and Windows64. It will also output plain binary files. Its syntax
is designed to be simple and easy to understand, similar to Intel's but less
complex. It supports all currently known x86 architectural extensions, and
has strong support for macros.")
- (supported-systems '("x86_64-linux" "i686-linux"))
(license license:bsd-3)))
(define-public yasm