summaryrefslogtreecommitdiff
path: root/gnu/packages/assembly.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/assembly.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/assembly.scm')
-rw-r--r--gnu/packages/assembly.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 675663047e..bcb42a083f 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -68,8 +68,8 @@
(base32
"0gqand86b0r86k3h46dh560lykxmxqqywz5m55kgjfq7q4lngbrw"))))
(build-system gnu-build-system)
- (native-inputs `(("perl" ,perl) ;for doc and test target
- ("texinfo" ,texinfo)))
+ (native-inputs (list perl ;for doc and test target
+ texinfo))
(arguments
`(#:test-target "test"
#:phases
@@ -140,7 +140,7 @@ debugging information in STABS, DWARF 2, and CodeView 8 formats.")
(base32
"1jgxbq2cm51dzi3zhz38mmgwdcgs328mfl8iviw8dxn6dn36p1gd"))))
(build-system gnu-build-system)
- (native-inputs `(("zlib" ,zlib)))
+ (native-inputs (list zlib))
(arguments
;; Some tests fail when run in parallel.
`(#:parallel-tests? #f))
@@ -324,12 +324,9 @@ runtime")
,(string-append "PREFIX="
(assoc-ref %outputs "out")))))
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)
- ("pkg-config" ,pkg-config)
- ("util-linux" ,util-linux)))
+ (list bison flex pkg-config util-linux))
(inputs
- `(("libpng" ,libpng)))
+ (list libpng))
(home-page "https://github.com/gbdev/rgbds")
(synopsis "Rednex Game Boy Development System")
(description
@@ -402,7 +399,7 @@ Supported architectures are:
(modify-phases %standard-phases
(delete 'configure)) ; no "configure" script
#:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))))
- (native-inputs `(("perl" ,perl)))
+ (native-inputs (list perl))
(home-page "https://www.floodgap.com/retrotech/xa/")
(synopsis "Two-pass portable cross-assembler")
(description