summaryrefslogtreecommitdiff
path: root/gnu/packages/assembly.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-01-09 19:28:02 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-01-09 19:33:27 +0100
commit1bde3d2cbf311f6d6c733339a000b7395cb2f945 (patch)
tree952e531d4e76911556859308c45cca713dceaceb /gnu/packages/assembly.scm
parentab7aa06cac4f0695d08ac84eb715b98962c49fa9 (diff)
downloadguix-patches-1bde3d2cbf311f6d6c733339a000b7395cb2f945.tar
guix-patches-1bde3d2cbf311f6d6c733339a000b7395cb2f945.tar.gz
gnu: Add dev86.
* gnu/packages/assembly.scm (dev86): New variable.
Diffstat (limited to 'gnu/packages/assembly.scm')
-rw-r--r--gnu/packages/assembly.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 813eea466f..d7a5e2c4bf 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -168,3 +168,40 @@ It does multiple passes to optimize machine code.It have macro abilities and
focus on operating system portability.")
(home-page "https://flatassembler.net/")
(license license:bsd-2)))
+
+(define-public dev86
+ (package
+ (name "dev86")
+ (version "0.16.21")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://v3.sk/~lkundrak/dev86/Dev86src-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "154dyr2ph4n0kwi8yx0n78j128kw29rk9r9f7s2gddzrdl712jr3"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:parallel-build? #f ; They use submakes wrong
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:system "i686-linux" ; Standalone ld86 had problems otherwise
+ #:tests? #f ; No tests exist
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'mkdir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/bin"))
+ (mkdir-p (string-append out "/man/man1"))
+ #t))))))
+ (synopsis "Intel 8086 (primarily 16-bit) assembler, C compiler and
+linker")
+ (description "This package provides a Intel 8086 (primarily 16-bit)
+assembler, a C compiler and a linker. The assembler uses Intel syntax
+(also Intel order of operands).")
+ (home-page "https://github.com/jbruchon/dev86")
+ (supported-systems '("i686-linux" "x86_64-linux"))
+ (license license:gpl2+)))