summaryrefslogtreecommitdiff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-07-23 12:19:19 +0200
committerLudovic Courtès <ludo@gnu.org>2018-07-23 12:25:31 +0200
commita2908f5aae6484b537067ec854871f608ccce92f (patch)
tree359bf00c67e1de130ab6a3a5dead5d9fe38a4a18 /gnu/packages/aspell.scm
parent10df28d74d1f799969d3ce37348c44efb1067c7f (diff)
downloadguix-patches-a2908f5aae6484b537067ec854871f608ccce92f.tar
guix-patches-a2908f5aae6484b537067ec854871f608ccce92f.tar.gz
gnu: aspell: Allow filters to be found.
Reported by Pierre-Antoine Rouby. * gnu/packages/aspell.scm (aspell)[arguments]: Add 'set-filter-path' phase.
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index 82136a28e8..993dc560eb 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -27,6 +27,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix licenses)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
@@ -49,6 +50,19 @@
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'build 'set-filter-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Change the default value of 'filter-path' so that filters such
+ ;; as 'tex-filter.so' can be found. By default none of the
+ ;; filters would be found.
+ (let* ((out (assoc-ref outputs "out"))
+ (libdir (string-append out "/lib/aspell-"
+ ,(version-major+minor version))))
+ (substitute* "common/config.cpp"
+ (("\"filter-path(.*)DICT_DIR" _ middle)
+ (string-append "\"filter-path" middle
+ "\"" libdir "\"")))
+ #t)))
(add-after 'install 'wrap-aspell
(lambda* (#:key outputs #:allow-other-keys)
(let ((bin/aspell (string-append (assoc-ref outputs "out")