summaryrefslogtreecommitdiff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-14 22:30:24 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-14 22:30:24 +0100
commit4554d6b77e0f306a3dc33a8c1f68c9a302967a08 (patch)
tree8ad23db223c418a13db6f9fe70e043ed9134aa5a /gnu/packages/aspell.scm
parentbb750fa0212fc565a1ecf8a03ce97820c5743c93 (diff)
downloadguix-patches-4554d6b77e0f306a3dc33a8c1f68c9a302967a08.tar
guix-patches-4554d6b77e0f306a3dc33a8c1f68c9a302967a08.tar.gz
gnu: aspell: Truly honor $ASPELL_DICT_DIR.
Fixes <https://bugs.gnu.org/29686>. Reported by Oleg Pykhalov <go.wigust@gmail.com>. * gnu/packages/aspell.scm (aspell)[arguments]: Remove 'wrap-aspell' phase. * gnu/packages/patches/aspell-default-dict-dir.patch: Add hunk to expand the right-hand size of '|' in values like "<$FOO|$BAR/baz>". Change DICT_DIR to refer to "$HOME" on the right-hand side.
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index 4f6f1a1cca..f0e0fbcc21 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
@@ -65,14 +65,6 @@
(("\"filter-path(.*)DICT_DIR" _ middle)
(string-append "\"filter-path" middle
"\"" libdir "\"")))
- #t)))
- (add-after 'install 'wrap-aspell
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((bin/aspell (string-append (assoc-ref outputs "out")
- "/bin/aspell")))
- (wrap-program bin/aspell
- '("ASPELL_CONF" "" =
- ("${ASPELL_CONF:-\"dict-dir ${GUIX_PROFILE:-$HOME/.guix-profile}/lib/aspell\"}")))
#t))))))
(inputs `(("perl" ,perl)))