summaryrefslogtreecommitdiff
path: root/gnu/packages/aspell.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-11-16 09:34:27 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-16 09:34:27 +0100
commit154d97abdd16674fdebc763351f661bbcdc869a4 (patch)
tree0277a9380edd1390f16e432283d32499ffed36d1 /gnu/packages/aspell.scm
parente4696c69d75f4fcf54c42beeb928032726bdaf7d (diff)
parent87e7faa2ae641d8302efc8b90f1e45f43f67f6da (diff)
downloadguix-patches-154d97abdd16674fdebc763351f661bbcdc869a4.tar
guix-patches-154d97abdd16674fdebc763351f661bbcdc869a4.tar.gz
Merge remote-tracking branch master into core-updates
Diffstat (limited to 'gnu/packages/aspell.scm')
-rw-r--r--gnu/packages/aspell.scm37
1 files changed, 22 insertions, 15 deletions
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index 70d0561004..56d69fdb05 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -149,18 +149,27 @@ dictionaries, including personal ones.")
"1svls9p7rsfi3hs0afh0cssj006qb4v1ik2yzqgj8hm10c6as2sm")))
(define-public aspell-dict-ca
- (aspell-dictionary "ca" "Catalan"
- #:version "2.1.5-1"
- #:sha256
- (base32
- "1fb5y5kgvk25nlsfvc8cai978hg66x3pbp9py56pldc7vxzf9npb")))
+ (let ((version "2.5.0")
+ (sha256
+ (base32 "0kbi8fi7a1bys31kfqrlh332gyik0cfdmxgl7n15sa9c305rkgwq")))
+ (package
+ (inherit (aspell-dictionary "ca" "Catalan"
+ #:version version
+ #:sha256 sha256))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.softcatala.org/pub/softcatala/aspell/"
+ version "/aspell6-ca-" version ".tar.bz2"))
+ (sha256 sha256)))
+ (home-page "https://www.softcatala.org/pub/softcatala/aspell/"))))
(define-public aspell-dict-de
(aspell-dictionary "de" "German"
- #:version "20030222-1"
+ #:version "20161207-7-0"
#:sha256
(base32
- "01p92qj66cqb346gk7hjfynaap5sbcn85xz07kjfdq623ghr8v5s")))
+ "0wamclvp66xfmv5wff96v6gdlnfv4y8lx3f8wvxyzm5imwgms4n2")))
(define-public aspell-dict-da
(aspell-dictionary "da" "Danish"
@@ -180,10 +189,10 @@ dictionaries, including personal ones.")
(define-public aspell-dict-en
(aspell-dictionary "en" "English"
- #:version "2018.04.16-0"
+ #:version "2019.10.06-0"
#:sha256
(base32
- "0bxxdzkk9g27plg22y9qzsx9cfjw3aa29w5bmzs561qc9gkp247i")))
+ "1zai9wrqwgb9z9vfgb22qhrvxvg73jg0ix44j1khm2f6m96lncr4")))
(define-public aspell-dict-eo
(aspell-dictionary "eo" "Esperanto"
@@ -282,19 +291,17 @@ dictionaries, including personal ones.")
(define-public aspell-dict-pt-br
(aspell-dictionary "pt_BR" "Brazilian Portuguese"
- #:version "20090702-0"
- #:prefix "aspell6-"
+ #:version "20131030-12-0"
#:sha256
(base32
- "1y09lx9zf2rnp55r16b2vgj953l3538z1vaqgflg9mdvm555bz3p")))
+ "1xqlpk21s93c6blkdnpk7l62q9fxjvzdv2x86chl8p2x1gdrj3gb")))
(define-public aspell-dict-pt-pt
(aspell-dictionary "pt_PT" "Portuguese"
- #:version "20070510-0"
- #:prefix "aspell6-"
+ #:version "20190329-1-0"
#:sha256
(base32
- "1mnr994cwlag6shy8865ky99lymysiln07mbldcncahg90dagdxq")))
+ "0ld0d0ily4jqifjfsxfv4shbicz6ymm2gk56fq9gbzra1j4qnw75")))
(define-public aspell-dict-ru
(aspell-dictionary "ru" "Russian"