summaryrefslogtreecommitdiff
path: root/gnu/packages/apr.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-07-18 00:52:45 +0200
committerLudovic Courtès <ludo@gnu.org>2014-07-18 00:52:45 +0200
commite5b648e06ace9623a368f1d8c18f35612f56ce79 (patch)
treeb45cc7b3b03b47675373875d5243fd90ea2dfa1f /gnu/packages/apr.scm
parent9f9236b766ad9c112eab2c72cdf43eca8ae4d26a (diff)
downloadguix-patches-e5b648e06ace9623a368f1d8c18f35612f56ce79.tar
guix-patches-e5b648e06ace9623a368f1d8c18f35612f56ce79.tar.gz
gnu: apr-util: Run 'make check' sequentially.
* gnu/packages/apr.scm (apr-util)[arguments]: Add #:parallel-tests?.
Diffstat (limited to 'gnu/packages/apr.scm')
-rw-r--r--gnu/packages/apr.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/apr.scm b/gnu/packages/apr.scm
index 93609ad5ca..26b49a5756 100644
--- a/gnu/packages/apr.scm
+++ b/gnu/packages/apr.scm
@@ -85,7 +85,13 @@ around or take advantage of platform-specific deficiencies or features.")
(system* "./configure"
(string-append "--prefix=" out)
(string-append "--with-apr=" apr)))))
- %standard-phases)))
+ %standard-phases)
+
+ ;; There are race conditions during 'make check'. Typically, the
+ ;; 'testall' executable is not built yet by the time 'make check' tries
+ ;; to run it. See
+ ;; <http://lists.gnu.org/archive/html/guix-devel/2014-03/msg00261.html>.
+ #:parallel-tests? #f))
(home-page "http://apr.apache.org/")
(synopsis "One of the Apache Portable Runtime Library companions")
(description