summaryrefslogtreecommitdiff
path: root/gnu/packages/apr.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-05-07 04:43:01 -0400
committerMark H Weaver <mhw@netris.org>2015-05-07 05:06:26 -0400
commit9f9d073be16b042fe0ecc1c46aea73c1fe657fe6 (patch)
treed69eac62475e4f664d2df9340a5d82d3bec24e67 /gnu/packages/apr.scm
parentc716f5a0e063b4dab4db5ade44b970edd51cec53 (diff)
downloadguix-patches-9f9d073be16b042fe0ecc1c46aea73c1fe657fe6.tar
guix-patches-9f9d073be16b042fe0ecc1c46aea73c1fe657fe6.tar.gz
gnu: apr-util: Use system expat library.
* gnu/packages/apr.scm: Import (guix licenses) with prefix "l:". (apr)[license]: Adapt to license prefix. (apr-util)[propagated-inputs]: Add expat. [arguments]: Pass --with-expat to configure. [license]: Adapt to license prefix.
Diffstat (limited to 'gnu/packages/apr.scm')
-rw-r--r--gnu/packages/apr.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/apr.scm b/gnu/packages/apr.scm
index 57f0443658..8c57ee3ab2 100644
--- a/gnu/packages/apr.scm
+++ b/gnu/packages/apr.scm
@@ -18,12 +18,13 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages apr)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix l:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages xml)
#:use-module (gnu packages autotools))
(define-public apr
@@ -59,7 +60,7 @@ an API to which software developers may code and be assured of predictable if
not identical behaviour regardless of the platform on which their software is
built, relieving them of the need to code special-case conditions to work
around or take advantage of platform-specific deficiencies or features.")
- (license asl2.0)))
+ (license l:asl2.0)))
(define-public apr-util
(package
@@ -74,19 +75,23 @@ around or take advantage of platform-specific deficiencies or features.")
"0bn81pfscy9yjvbmyx442svf43s6dhrdfcsnkpxz43fai5qk5kx6"))))
(build-system gnu-build-system)
(inputs
- `(("apr" ,apr)))
+ `(("apr" ,apr)))
+ (propagated-inputs
+ `(("expat" ,expat)))
(arguments
'(#:phases
(alist-replace
'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (apr (assoc-ref inputs "apr")))
+ (let ((out (assoc-ref outputs "out"))
+ (apr (assoc-ref inputs "apr"))
+ (expat (assoc-ref inputs "expat")))
(setenv "CONFIG_SHELL" (which "bash"))
(zero?
(system* "./configure"
(string-append "--prefix=" out)
- (string-append "--with-apr=" apr)))))
+ (string-append "--with-apr=" apr)
+ (string-append "--with-expat=" expat)))))
%standard-phases)
;; There are race conditions during 'make check'. Typically, the
@@ -98,4 +103,4 @@ around or take advantage of platform-specific deficiencies or features.")
(synopsis "One of the Apache Portable Runtime Library companions")
(description
"APR-util provides a number of helpful abstractions on top of APR.")
- (license asl2.0)))
+ (license l:asl2.0)))