summaryrefslogtreecommitdiff
path: root/gnu/packages/apl.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-05-02 11:17:16 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-02 15:14:44 +0200
commit94b1905580527c0067b3effb9cf083dd16d4eaa9 (patch)
tree3a96553f5c78db17aef56e6d75548932f0f09154 /gnu/packages/apl.scm
parent35e5d2ce56cef2f6222140032ec7baa65d3b6cc7 (diff)
downloadguix-patches-94b1905580527c0067b3effb9cf083dd16d4eaa9.tar
guix-patches-94b1905580527c0067b3effb9cf083dd16d4eaa9.tar.gz
gnu: apl: Update to 1.8-r1550.
This commit fixes a failing build caused by -Werror (the configure script no longer sets the -Werror compilation flag). * gnu/packages/apl.scm (apl): Update to 1.8-r1550. [arguments]: Add 'fix-configure' phase. [license]: Prefix with 'license:'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/apl.scm')
-rw-r--r--gnu/packages/apl.scm74
1 files changed, 46 insertions, 28 deletions
diff --git a/gnu/packages/apl.scm b/gnu/packages/apl.scm
index badec04333..ad9f4504bf 100644
--- a/gnu/packages/apl.scm
+++ b/gnu/packages/apl.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,9 +20,10 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages apl)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix git-download)
+ #:use-module (guix svn-download)
#:use-module (guix packages)
- #:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages gettext)
#:use-module (gnu packages maths)
@@ -30,30 +32,46 @@
#:use-module (gnu packages sqlite))
(define-public apl
- (package
- (name "apl")
- (version "1.8")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/apl/apl-" version ".tar.gz"))
- (sha256
- (base32
- "1jxvv2h3y1am1fw6r5sn3say1n0dj8shmscbybl0qhqdia2lqkql"))))
- (build-system gnu-build-system)
- (home-page "https://www.gnu.org/software/apl/")
- (inputs
- `(("gettext" ,gettext-minimal)
- ("lapack" ,lapack)
- ("pcre" ,pcre2)
- ("sqlite" ,sqlite)
- ("readline" ,readline)))
- (arguments
- `(#:configure-flags (list (string-append
- "--with-sqlite3="
- (assoc-ref %build-inputs "sqlite")))))
- (synopsis "APL interpreter")
- (description
- "GNU APL is a free interpreter for the programming language APL. It is
+ (let ((revision 1550))
+ (package
+ (name "apl")
+ (version (string-append "1.8-r" (number->string revision)))
+ (source
+ (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url "svn://svn.savannah.gnu.org/apl/trunk")
+ (revision revision)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bgc3a09f35zrqq2irhm1hspppnxjqas0fmcw14hkc7910br9ip3"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.gnu.org/software/apl/")
+ (inputs
+ `(("gettext" ,gettext-minimal)
+ ("lapack" ,lapack)
+ ("pcre" ,pcre2)
+ ("sqlite" ,sqlite)
+ ("readline" ,readline)))
+ (arguments
+ `(#:configure-flags (list (string-append
+ "--with-sqlite3="
+ (assoc-ref %build-inputs "sqlite")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-configure
+ (lambda _
+ (substitute* "buildtag.sh"
+ ;; Don't exit on failed SVN-related calls.
+ (("^ +return 0\n") "")
+ ;; Manually set the SVN revision, since the directory is
+ ;; unversioned and we know it anyway.
+ (("^SVNINFO=.*")
+ ,(string-append "SVNINFO=" (number->string revision) "\n"))
+ ;; Requires running ‘svn info’ on a versioned directory.
+ (("\\\\\"\\$ARCHIVE_SVNINFO\\\\\"") "\\\"\\\"")))))))
+ (synopsis "APL interpreter")
+ (description
+ "GNU APL is a free interpreter for the programming language APL. It is
an implementation of the ISO standard 13751.")
- (license gpl3+)))
+ (license license:gpl3+))))