summaryrefslogtreecommitdiff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-08-11 13:12:28 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-08-11 13:12:28 +0200
commited62aa0af5e6801c398d59c3d67a42d61b060ada (patch)
treecccacc9a8396b231a7d38d5dc558fc410105c8f8 /gnu/packages/android.scm
parenta2954e2a44602a5b5d50e11428f18023395fbf1c (diff)
downloadguix-patches-ed62aa0af5e6801c398d59c3d67a42d61b060ada.tar
guix-patches-ed62aa0af5e6801c398d59c3d67a42d61b060ada.tar.gz
gnu: android-liblog: Install headers.
* gnu/packages/android.scm (android-liblog): Install headers in a new phase.
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 69366693a4..3c3a9cd594 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -201,7 +201,16 @@ use their packages mostly unmodified in our Android NDK build system.")
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(symlink "liblog.so.0" (string-append out "/lib/liblog.so"))
- #t))))))
+ #t)))
+ (add-after 'install 'install-headers
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (copy-recursively
+ "../include/log" (string-append out "/include/log"))
+ ;; For android/log.h, the only header in the android directory.
+ (copy-recursively
+ "../include/android" (string-append out "/include/android")))
+ #t)))))
(home-page "https://developer.android.com/")
(synopsis "Logging library from the Android platform.")
(description "@code{liblog} represents an interface to the volatile Android