summaryrefslogtreecommitdiff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-08-31 15:20:13 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-31 15:20:13 +0200
commite227b0820a93c4a264a169895948d6d2c0c37005 (patch)
tree23e29aa6acabdf65a1c1748e3baf85df5bd62add /gnu/packages/android.scm
parent2ac1978a9fe7632f1151da8a3510aadeeb7708ae (diff)
downloadguix-patches-e227b0820a93c4a264a169895948d6d2c0c37005.tar
guix-patches-e227b0820a93c4a264a169895948d6d2c0c37005.tar.gz
gnu: android-ext4-utils: Fix build.
* gnu/packages/android.scm (android-ext4-utils)[arguments]: Use gexp for 'make-flags'. Update 'unpack-core' phase.
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm30
1 files changed, 12 insertions, 18 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 630a626ba2..a747b0c9b5 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -532,29 +532,23 @@ the core SELinux management utilities.")
(build-system android-ndk-build-system)
(arguments
`(#:make-flags
- (list (string-append "CPPFLAGS="
- ;"-Wno-error "
- "-I "
- (assoc-ref %build-inputs "android-libselinux")
- "/include "
- "-I " (assoc-ref %build-inputs "android-libsparse")
- "/include "
- "-I " (assoc-ref %build-inputs "android-libcutils")
- "/include "
- "-I " (assoc-ref %build-inputs "android-liblog") "/include "
- "-I ../core/include")
- "CFLAGS=-Wno-error"
- "install-libext4_utils_host.a"
- (string-append "prefix=" (assoc-ref %outputs "out")))
+ ,#~(list (string-append "CPPFLAGS="
+ ;"-Wno-error "
+ "-I " #$android-libselinux "/include "
+ "-I " #$android-libsparse "/include "
+ "-I " #$android-libcutils "/include "
+ "-I " #$android-liblog "/include "
+ "-I ../core/include")
+ "CFLAGS=-Wno-error"
+ "install-libext4_utils_host.a"
+ (string-append "prefix=" #$output))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'unpack-core
(lambda* (#:key inputs #:allow-other-keys)
(mkdir-p "core")
- (with-directory-excursion "core"
- (invoke "tar" "axf" (assoc-ref inputs "android-core")
- "--strip-components=1"))
- #t))
+ (copy-recursively (assoc-ref inputs "android-core")
+ "core")))
(add-after 'unpack-core 'enter-source
(lambda _ (chdir "ext4_utils") #t))
(replace 'install