summaryrefslogtreecommitdiff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-08 15:38:29 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-08 15:42:33 +0100
commit852ad65bd45a81a441a85318badf17a005cad111 (patch)
tree6b65cfff79b0cee7706fb079bc957cadb9222267 /gnu/packages/android.scm
parent5573d98f81169802509f8c4573d65fae78137166 (diff)
downloadguix-patches-852ad65bd45a81a441a85318badf17a005cad111.tar
guix-patches-852ad65bd45a81a441a85318badf17a005cad111.tar.gz
gnu: fastboot: Fix ‘--version’ output.
* gnu/packages/android.scm (fastboot)[arguments]: Replace broken ‘git rev-parse’ shell command with the actual package VERSION. Reported by kwjc on #guix.
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 016943e0f0..74d97ab3b6 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -668,7 +668,8 @@ file system.")
(add-after 'enter-source 'patch-source
(lambda _
(substitute* "Android.mk"
- (("libext4_utils_host") "libext4_utils_host libselinux libpcre"))
+ (("libext4_utils_host") "libext4_utils_host libselinux libpcre")
+ (("\\$\\(shell git .*\\)") ,version))
#t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)