summaryrefslogtreecommitdiff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-04-26 02:16:00 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-05-09 19:16:43 +0200
commit3724d375778b11c6f857138198329e3b99984af5 (patch)
tree9f5adb4ce98d6e088f2e7ed852135c58385beda8 /gnu/packages/android.scm
parentf6e75b0db28bf3ba0e402069b0fc173411d414af (diff)
downloadguix-patches-3724d375778b11c6f857138198329e3b99984af5.tar
guix-patches-3724d375778b11c6f857138198329e3b99984af5.tar.gz
gnu: mkbootimg: Install "bootimg.h".
* gnu/packages/android.scm (mkbootimg)[arguments]<#:phases>[install]: Install "bootimg.h".
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 085bf41aeb..53b0183f92 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -256,8 +256,10 @@ to a Unix shell that can run commands on the connected device or emulator.")
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
+ (bin (string-append out "/bin"))
+ (include (string-append out "/include")))
(install-file "mkbootimg" bin)
+ (install-file "bootimg.h" include)
#t))))))
(home-page "https://developer.android.com/studio/command-line/adb.html")
(synopsis "Tool to create Android boot images")